Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Jira Cloud issue view: Insert attachments already on an issue

Hi Community,

I’m Ahmud, a product manager working on the issue view in Jira Cloud (Jira Software, Jira Service Management, Jira Work Management).

Today we’re announcing a feature many of you have been asking for: the ability to insert attachments already on an issue in the new issue view.

How it works

 1.gif 2.gif


To try it out, just go to an issue, open up a multiline text field or a comment, and use one of these:

  • From the editor’s toolbar, select + > Attachments on this issue.

  • Type /reference and select Attachments on this issue. Alternatively, you can type /file, /attach, or /insert to include other things in your search too.

Learn more about inserting attachments.

Give us feedback

If you have any questions or feedback, leave us a comment in the section below. We’d love to hear what you think about this new feature.


It's a progress, but it is also very disappointing that images inserted directly with an upload and images inserted from existing attachments behave very differently. From attachments they get included as non-resizable thumbnails.

It would be understandable as a quick fix or a half-baked workaround, but after 3+ years of waiting and more than a year active development, it could have been more polished.

Like # people like this

Fully agree with @Andrew Maltsev 

Selling us this as a feature.... ridiculous
It's a bugfix, and a poorly made one too...

Like Pujanito likes this

Thank you for the work @Ahmud Auleear , but it is a bug fix, not a new feature. Just saying...

The thumbnail is a bit of a buzzkill...

Additionally, when creating an internal note, "Internal only" attachments (originally added via an internal note) can't be selected...


Like # people like this

@Ahmud Auleear , what @Michael Merrifield is describing is a very common use-case in Jira Service Management.  You and other colleagues will add internal attachments as you are researching something with some internal jargon and then eventually use all of the existing attachments in an external comment for the customer (once you have all of the details together in order to explain everything to them in a customer-friendly way).  If you do not have comment editing permissions, you then need to download/upload these attachments again (even with this slash function in place).


If you add the attachments in Old View as internal only (in browse or an internal comment), you can now grab them later in New View with this new function, but if you happen to add them as part of an internal comment in New View, they are locked out from this new functionality.  In a side note, on top of this locked down problem, it would be great to just add internal attachments and not make them a comment in New View (when you just need to add a couple of files for later use that are not intended to go with a comment at the time).


Also, we are not able to use existing attachments on transition screens since they do not yet use the new editor (that was another place that you would add them in Old View... not really sure why that bug popped up since those screens use the old view, but we are still blocked there).


Good start, but hoping these last two pieces can be fixed.  Thanks!

Like # people like this

Yeah after over 3 years of waiting and over a year of active "in progress" with high priority, this is more a "meeh", than "cool!".

And the same as others, I don't understand why attachments can't be selected for internal comments.

Also, translation doesn't work for the Macro to select Attachments, just saying.

If half the time that Atlassian employees spend for social causes and diversity and whatnot were spent on providing a good customer experience, we wouldn't be in this mess that a bug fix after many years is being sold as a feature, and it is not even working properly. Hope you guys find your focus soon.

Like Richard Shepley likes this

Not being able add an attachment that was uploaded as an internal comment means this is still not working correctly.

We could do this in server before we were forced on to cloud. Agents need to be able to insert any attachment already on the ticket as a public comment. 

Please fix this.

Like Bojana Vasic likes this

I agree with other comments here that without being able to add an internal attachment means to me that this is not complete. This also seems hidden in the (+) menu in the editor. Feels like it should be more visible. There's plenty of room in the editor's toolbar, or it could even be combined with the Files and Images function.

Like # people like this

I think @Diego Lopez wrote a comment about how existing internal attachments cannot be referenced/reused (JRACLOUD-80457) in this fixed version of the bug, but maybe that comment was deleted?  @Ahmud Auleear is that being worked on?  We need to be able to use those existing attachments in comments along with public attachments.  It is fine to keep the indicator to show it was originally an internal attachment when you are selecting from the list, but all attachments are needed in this function.

Although I voted for the issue and wanted a solution, I have not been following this issue closely. Our Cloud migration is stalled by other blocking issues. Sorry for the late comment on this post.

After trying the new 'feature' today on our Cloud instance I was immediately disappointed - as noted by @Andrew Maltsev and others here.

Yes the changes technically resolve JRACLOUD-72208, but when inserting image attachments (our main use-case) it doesn't work as well as Jira Server. On Server you can control how the image is rendered in the description/comment.

You've managed to make a whole new type of image in Description/Comment fields which cannot be resized!?

Certainly well below our hopes and expectations.

Are there any plans to further improve or refine this?

@Ahmud Auleear As noted above - thanks for fixing part of the issue; yes you can now insert an image (or other existing attachment) into a comment or description. But after inserting an image you cannot format it.

In short - this behaves differently to a normal image.

There is another JAC ticket JRACLOUD-80640 that relates to resizing images. Perhaps this should cover the other gaps too (alignment, wrapping, external link, and alt-text).

How can I dislike a community post? This workaround is surely not what all the community expects...

@Ahmud Auleear @Jehan Gonsalkorale and @Simon Herd  any updates on this?  Will we be able to reference existing internal attachments soon?  Right now you can only reference public attachments (a big use-case is working on things internally and then sending out a public comment with visual references from the initial work at a later time).


Log in or Sign up to comment
AUG Leaders

Atlassian Community Events