Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,426
Community Members
 
Community Events
176
Community Groups

Bug with Group Selection in Global Permissions

I noticed @-mentions were not working. So I followed the advice on Mentions and autocomplete not working.

I noticed I couldn't complete the step where I select the browse users permission and group down at the bottom of the global permissions page. I was only presented with the public option (German: "Öffentlich"). Same goes for the other permissions.

Once I added public, I suddenly was able to choose from the list of actual groups. After adding the desired group jira-core-users I was able to remove the public group again... see screenshots. 2021-05-26 13_18_59-Globale Berechtigungen - Jira.png2021-05-26 13_19_19-Globale Berechtigungen - Jira.png I was able to reproduce this multiple times as removing the last group from "Browse users and groups" caused "Public" being the only option to add to this group.

I tried to report this as a bug, but it was not possible due to the free tier I'm using.

Maybe this helps someone with the same issue, or maybe someone can actually report this as a bug.

Cheers

2 answers

Hi @sepp,

I don't have a free plan at my disposal to simulate, but it is definitely so that permission settings on that plan are limited, as you can see in This support article.

Besides that, in the eventuality that you might be able to configure these global settings, you need to have one or more groups configured before you can use them in global permissions settings. Next, searching for these groups is case sensitive. If you know you have groups available in your site, just see if you can find them here by typing the group name in the search box.

If they appear, problem solved - I hope. If they don't, you are probably running into free plan limitations.

Hope this helps!  

Thanks @Walter Buggenhout _ACA IT_ Indeed, I have multi groups. I guess that's why I was able to select the groups that I did (ended up with default jira-core-users) after choosing public first and removing it afterwards.

I can't see the groups I have if I enter them in the search box

0 votes
John Funk Community Leader May 26, 2021

Hi @sepp  - Yes, Permissions are tightly controlled in the free product with very little changes being possible. I am actually surprised you were even able to change some of the things you did. Not sure that Atlassian would consider that a Bug, but I will let them consider that.  :-)

afaik, the permissions restrictions are only on a project-level. For global permissions this should be possible (if I read the support articles right).

Like John Funk likes this
John Funk Community Leader May 26, 2021

Definitely strange behavior. Are you a member of the group you are trying to add (when it is not public)? Atlassian doesn't let you do much with a group if you are not a member of that group. 

Yes, I'm a member.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
FREE
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events