Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Must set siteid request error in JQL query

HI All,

I have had perfectly working Jqery in Excel add-in linked to Jira Cloud (tom import data), I am now getting Must set "siteid" request error  as an error. Any ideas 

3 answers

I had the same issue. I logged out and logged in again and no more error message.

@Monelle I logged off the Jira cloud but my Excel addin still has the same error message. I've closed & re-opened Excel to no avail. It feels like there's some other way I need to log out but IDK how. I know that occasionally the Excel addin will have me reauthenticate against my cloud credentials, but it's not having me do that now and IDK how to trigger it. Can you advise, please what you did to log out/in and resolve your issue?

I was able to do the following to get it to work. I closed the spreadsheet with the query embedded in the add-in and got out of Excel completely. Then, I opened a new spreadsheet and when the Jira add-in opened to the right, I went through a fresh authentication there (where it takes you to the site and gives you the six digit code). Once I did that, reopening the original file with the query embedded worked and it refreshed. Hope this helps for your situation as well.

I am using a very simple JQL Query Sprint = 157 order by created DESC and I get  Must set "siteid" request error  as an error.   This is frustrating!  Any reason why this is happening NOW????? 

I have the same problem...

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events