Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I can't add a new column on my filter

Hi, 

I've created a Filter on a specific board. 
I had the column Key on My default view - Now I don't have it anymore. When I try to add it, it doesn't show up. 

On monday, I've exported this filter on a spreadsheet, the Key was present, now it's not anymore. I did not change anything on my filter. 

 

I need to add it urgently back! What can I do? 
Everytime I try to add it back, I click on Done but I don't see the column appearing. 

2 answers

Hi,

 

@Marie Thuy Was there ever a resolution to this issue?  I am experiencing similar issues where my saved filters do not respect the columns saved at that time.  They seem to change to whatever the most recent column/field settings that I have used.  I cannot seem to get the filter vs My Defaults to work either.   My guess is that this https://jira.atlassian.com/browse/JRASERVER-30714 will resolve this? but it's been open since 2012 and is still gathering interest.... 

 

thanks

Daniel Ebers Community Leader Aug 01, 2021

Hi @Frank Basler

welcome to the Atlassian Community - not sure if this older thread here will get a lot of attention - but at least some ideas, the linked Suggestion is for Jira Server, so it would apply if you are indeed using Jira server.

Are you using Jira Server or Jira Cloud?

If I understand it correctly (and remember it correctly) the question from the user above was that added fields to the columns did not save, rather than the order of the columns.

When you want to explain it a bit in detail and state if you are using Jira Server / Jira Cloud we could consider what to do next (new thread or trying here to see for a fix).

Regards,
Daniel

Hello @Marie Thuy 

Welcome to the community.

Have you made sure that the field is not already selected but off to the right side of the screen where you need to scroll to see it?

Can you provide a screen image of the Column selection pop-up that shows all the columns you have selected, and what shows when you type in "key" to search for that column to select it?

In my cloud instance, the Key field is still available as a selectable column and displays properly.

Hi Trudy, 

Yes the field is not already selected (not sure why cause it was for sure) and not on the right side as well. 

Here are the screenshots: 

Capture d’écran 2021-01-22 à 17.45.10.pngCapture d’écran 2021-01-22 à 17.45.20.png

Yes I select Key and click on Done, nothing is happening. But if I select something else than the new column is appearing. 

Hello @Marie Thuy 

In the screen image, notice that "My Defaults" is selected. Those are the fields/columns selected for when you use Search without using a saved filter.

If this is a saved filter, the selected fields/columns will be shown and modified under the "Filter" option in the Column pop-up. The columns selected get saved with the filter so the same columns will show the next time the filter is used.

In my experience, though, changing the selected columns is not recognized by JIRA as a change to the filter, and the Save button for the filter is not activated. You have to change the filter criteria also. So, to save changes to selected columns with a saved filter, first change the columns, then change some aspect of the filter, then revert that aspect, then save the filter. I usually just change the sort order, then revert the sort order to the original specification.

Like Bill Sheboy likes this

Trudy, 

I did try to change in Column - Filters and tried to add the Key here. But also when I click on Done it's not saving it. 

I'm not sure to understand what I'm supposed to do. 

I tried to change the sort order and then click on Columns - Filter and add Key and then click on Done and nothing is happening. 

Could you please share some screenshots or a video? 

I did not touch anything on my saved filter, but since today the KEY is gone. No manipulation has been done in between. 

Hello Marie,

Step 1: Navigate to an entirely different screen in JIRA, just to make sure there is nothing cached in your browser concerning things you've tried to do to update the filter.

Step 2: In the Advanced Search screen open your saved filter, and switch to List View if you are not already there. Here is an example of a simple filter I saved where Key is not one of the displayed columns.

Screen Shot 2021-01-22 at 10.06.23 AM.png

Notice the button next to the filter name "Saved Filter Test". It is currently labeled "Save As" because no change has been made to the filter yet.

Step 3: Open the Columns selection and make sure the Filter tab is selected.

Screen Shot 2021-01-22 at 10.10.27 AM.png

This should show you a list of all the selected columns that are currently saved with the filter.

Step 4: In the search field type in Key.

Screen Shot 2021-01-22 at 10.12.34 AM.png

Step 5: Check the box next to Key, and then click on the Done button.

Screen Shot 2021-01-22 at 10.13.25 AM.png

This should add the Key column to your screen as the right-most column. If you have a large set of results. Give it a few moments. If it still hasn't displayed, try clicking the Search button.

Screen Shot 2021-01-22 at 10.15.22 AM.png

Notice that the Save button next to the filter name still says Save As. Jira doesn't recognize a change to the column selection as a change to the filter, so it is not going to "save" you column selection change with the filter at this point. If you navigated away from this screen and then came back and reloaded the filter, the Key column would not display.

Step 6: Change some aspect of the filter criteria or sort order. I'm changing the sort order from DESC to ASC. Then click the Search button. Notice that the button next to the filter name has now changed to "Save".

Screen Shot 2021-01-22 at 10.19.06 AM.png

 

Step 7: Save your filter.

Step 8: You probably don't want to keep this change to your filter, so revert the change you made. I'm changing the sort order from ASC back to DESC. Then click the Search button again.

Your change to the selected Columns should now be saved with the filter. If you navigate away from this screen, then come back and load your saved filter again, the Key column should display.

As to why it may have disappeared from your filter when you think you have not made any changes, I cannot explain. 

@Trudy Claspill  I did exactly as you said, but every time I add in my filter the column Key, nothing is showing up. 
If I do it with another column it's working perfectly. 

Could you contact me, so I can share a screen recording about the issue? 

Like Jeff Dick likes this
Daniel Ebers Community Leader Jan 25, 2021

@Marie Thuy 
I found this sentence from Trudy interesting:

Step 1: Navigate to an entirely different screen in JIRA, just to make sure there is nothing cached in your browser concerning things you've tried to do to update the filter.

A step further - have you already tried to empty the browser's cache and to try a different browser by chance?
I am asking because lately we saw some cases here in Community where this was just caused by some strange caching in one browser .. or another :)

@Daniel Ebers Hi Daniel, 

I did all of this and unfortunately nothing is working. 
Would it be possible that we've blocked this filter? 
In System view I see it properly and with the filter I've created a dashboard and I see the Key Column in the dashboard. 

Daniel Ebers Community Leader Jan 25, 2021

I do not think this could be the cause. But you could enter the JQL query from scratch and try to align the columns (at least trying to add 'keys') - so you could rule a problem with the filter out.
But, to be honest (sadly) I could not imagine a positive contribution by doing so.

It doesn't seem to work either. 
Could someone from the Support contact me directly, so I can share my screen recording? Due to this I can't work properly. 

Daniel Ebers Community Leader Jan 25, 2021

Yes, sure - this would in general be an option, you can reach support here:
https://support.atlassian.com/contact/#/

(I hope this is okay with Trudy, she posted a lot a very correct and helpful screenshots - I am just saying this so in case she wants to contribute some further idea before goint ahead. I don't want to capture away this thread/the current efforts - but this, of course, is up to you how to proceed).

In case you want to report to support you could do us a favour if you could report back what you learned. Many thanks in advance!

I'm having the exact same issue as Marie. I even tried in Edge (I usually use Chrome) but get the same results.

I just went back to the filters that previously had the Key but weren't displaying it yesterday and the Key is now displaying. 

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Jira

Admins, notify your Jira instance of system-wide changes with the new admin announcement banner

Hi All! We’re excited to share the launch of an announcement banner that lets Jira site administrators communicate directly to their users across their  Jira Cloud instance.  ...

577 views 15 18
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you