Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,057
Community Members
 
Community Events
168
Community Groups

Connect self-hosted GitLab to Jira Cloud

Edited
Steven I'm New Here Aug 08, 2022

Hello everyone,

 

I have been trying to get GitLab integration working together with our IT for the past week, but simply can't get it to work. 
We have Jira Cloud and a self-hosted GitLab.

 

We have been using the documentation from GitLab that can be found here.

Everything up to step 4 is working fine for us. We try to connect to the manifest URL but receive a timeout since Jira seems to not be able to connect to our gitlab. The error is not very descriptive and simply says "Something went wrong. If the error keeps opccuring please write to Atlassian Support".

We did some further investigation and found out that there is a specific IP range we need to make available. This list research led us to this IP range page from Jira. We tried with this list of IP ranges, still no luck, still same issue.

The page with the above IP range list also mentioned a shorter List of IPs so we also tried that one. Still no luck.

 

We are now sadly out of options that my IT and I can think of. We hope to find someone with similar experience through here. 

 

Edit: Just remembered one thing to add... Our IT also tried allowing any connection to connect to GitLab. If this is done the application works. To us that indicates that there seems to be some IP or several IPs  that are not in the list and then make it impossible for the connection to work. Sadly there is no sort of log or anything where we could see which IP it is that we need to allow.

 

Again, just to cover our need and make clear what we are trying:

- We have Jira Cloud

- We have a self-managed GitLab

- Goal: Connect GitLab to Jira Cloud to allow the developer section in tickets to populate and be usable.

 

I appreciacte any kind of help/hint towards what we might be doing wrong.

0 answers

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS

Atlassian Community Events