Automation loop problem

Kamil Askerov March 17, 2024

When one of my automation worked - its looped and work many time. I see this lops in automation logs(there was logs about success comment on linked issue) Why its looped I don't understand. Also I had Elements Copy and Sync program by which I make migration from Jira server to cloud. This program was enabled. This loops are finished when i  disable Elements Copy and Sync's recipes. How I can solve this problem for future?

2 answers

0 votes
Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 19, 2024

Hi @Kamil Askerov 

You do not show this in your rule details image, but I suspect you have enabled the "Allow Rule Trigger" option, and because this rule adds comments it triggers itself...which seems like a bad idea for this scenario.

Please try disabling that option.

Kind regards,
Bill

0 votes
Stephen Wright _Elabor8_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 17, 2024

Hi @Kamil Askerov 

Could you provide us some more information here?

Specifically what the audit logs state, and what the rule itself looks like?

Ste

Kamil Askerov March 17, 2024

automation.pnglog.png

Kamil Askerov March 17, 2024

log have many information like in photo

Kamil Askerov March 17, 2024

@Stephen Wright _Elabor8_  I have more than 20 projects with automation like this but only problem in this one.

Stephen Wright _Elabor8_
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
March 21, 2024

Hi @Kamil Askerov 

I'd follow @Bill Sheboy's advice in the other answer - and check if the "allow other rule actions to trigger this rule" checkbox is checked:

  1. Go to your Rule
  2. Select Rule Details
  3. Check if "Check to allow other rule actions to trigger this rule. Only enable this if you need this rule to execute in response to another rule." is checked
  4. If yes, uncheck it 
  5. Retest the rule

Let us know how it goes :)

Ste

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events