Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,368,984
Community Members
 
Community Events
168
Community Groups

Setting value to the automation rule from insight cmdb

I am trying to create an automation rule to create automatic tasks monthly. Also, I have an Insight object type named "Assigned Group", and the teams are defined in this object type. I chose the Assigned Group field in my automation to assign an Assigned Group value to my automatically created task. I wrote the IQL to assign a group value in this field, but it does not work. For example, I have an object type named "Assigned Group" and it has objects like "Network", "System" etc under the "Name". and I want to assign "Network" group value to this task, so only one value (object) should be assigned to Assigned Group in the automation rule. Then when I check the created task, it shows as "None" even though I type the IQL. I guess there is a problem with IQL syntax. How can I solve this problem? What is the correct query to solve this problem?
ss.PNG

1 answer

Hi Elif,

 

objectType = "Assigned Group" AND Name = "Network" would be the correct way to set your team I think.

Also, if you click on the "Validate syntax" link, you'll always get an error message (it's a bug) but publish your rule and it should work.

 

Have a nice day

 

Frederic Chartrand

FMX Solutions - Gold Solution Partner

Hi @Frederic Chartrand , thanks for the answer. I've already tried this query before, but the Assigned Group is still returning as "None". Do you have any idea about that? ag.PNG

Is your custom field linked to your schema ? In the context of your custom field, the Insight configuration points to your schema and the Filter scope is something like objectType = "Assigned group" ?

Also, is the name of your objects right ?

You could also take a screenshot of your automation rule if it's still not working.

In the context of the custom field, there is no problem in the schema and the filter scope is objectType="Assigned Group". The name of my objects is correct. I put a screenshot of my automation rule below.
ttempsnip.png
Additionally, there is no problem in the audit log. What should I do about this problem?
temp.png

You can validate two more things :

1-Who's the actor of your automation rule and is this actor allowed to browse Insight objects ?

2-If you go in Insight and type the query objectType = "Assigned Group" AND Name = "Backup" do you see the group as a result ?

Also, you could show me a screenshot of the configuration of your field and a screenshot of your Insight schema.

But I'd look in the authorization of your actor in Insight first.

1- The actor of the automation rule is "Automation for Jira", but I am not sure about its permissions to browse Insight objects. In fact, I am not sure how to check its permissions.

2- Yes, I can see the group as a result when I type this query.
The name of the custom field is Assigned Group, and I want to retrieve one of the object type "Atama Grubu" objects as a value. For that, I typed the query as: objectType = "Atama Grubu" AND Name = "Backup"

agroup.png
schema.png

Finally got it !!!

Your IQL query says : objectType = "Assigned Group" but it is in fact the name of the field and not the objectType.

Try : Name LIKE "Backup" or Name = "Backup" in your IQL query to set your field in your automation (don't add the objectType = XXX since your field context is already connected to the correct objectType). You should see your team after.

Let me know !

I've tried the queries Name LIKE "Backup" and Name="Backup", but unfortunately, these are not working either. The Assigned Group field is still None as below. Do you have any other ideas about this problem?task.png

If you edit the request created, can you choose the different teams in your field ?

If you can't, maybe the context of your field has an error. I see that the schema connected is CMDB. Is this schema the one that contains your "Atama Grubu" objectType ?

Yes, I can choose a different team after the request is created, but the Assigned Group field is seen as still "None" after I select it manually. 
Yes, the schema CMDB contains the "Atama Grubu" objectType.

Resim1.png

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events