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Unable to login to Jira Align with a reverse proxy

Josh Miller
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April 10, 2024

Brand new installation of Jira Align and when we access Jira Align directly we are able to login with the default username / password. If we stand up an Apache reverse Proxy that is only modifying the port (IIS is responding on port 8080 and Apache is responding on port 80), We can no longer login. No error message appears, it just redirects back to the logon page.

There are no error messages and nothing in the logs. The Login does not appear in the Align logs whether it succeeded or failed.

1 answer

0 votes
Edvaldo Lima
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 11, 2024

G'Day @Josh Miller

Apologies for the broken link. in Case the issue is not resolved yet, you can try the following steps:

Cause

  • If the error 'Forms authentication failed for the request. Reason: The ticket supplied has expired' appears in the Windows Event Viewer (inside Windows Logs > Application - with source as ASP.NET 4.0), the cause can be the lack of time synchronization between the Web Server and the Database. Check the Solution #1 below.

  • If no error appears in the Windows Event Viewer, the root cause is still unknown but could be related to a browser or network blockage of HTTP traffic. Check Solution #2 below.

Solution

Solution 1:

If the error appears in the Windows Event Viewer, confirm if the time/time zones are in sync between the Web Server and the Database server.
Then after checking/fixing the time, clear the table tblLog with the command below, which should be run on the DB:

TRUNCATE TABLE tblLog;

 

Solution 2:

If no errors appear in the Windows Event Viewer or any of the other logs, make sure to test using the HTTPS access/bindings.

For that, you can ask the customer to use a valid certificate, or to create a self-signed certificate:

  1. Launch PowerShell as Administrator

  2. Run the following command:

    1. New-SelfSignedCertificate -DnsName "customerurl.jiraalign.com" -CertStoreLocation "cert:\LocalMachine\My"

  3. Start > type ‘cert’ and open "Manage computer certificates"

  4. Locate the certificate you just created under Personal > Certificates. Right-click > Copy

  5. Navigate to Trusted Root Certificate Authorities > Certificates. Right-click > Paste

  6. Launch the IIS Manager. Click on the website associated with JiraAlign > Bindings > Add:
    Type = https
    IP address = All Unassigned
    Port = 443
    Hostname = customerurl.jiraalign.com (should be the same as the one provided in the cert creation)
    SSL Certificate = <select the cert you just created from the drop-down>
    Click OK and restart IIS.

  7. If the URL is not resolved by the DNS yet, you will need to add it to the server's hosts file, usually under c:\Windows\System32\Drivers\etc\hosts. The format is: ServerIP customerurl.jiraalign.com

 

In case the issue persists, you can also raise a support ticket at https://support.atlassian.com and we'll assist you accordingly.

 

Josh Miller
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 11, 2024

That link for "Login not working" doesn't work for me, it just sends me to a Page Not found error.

the Support team just told me that if it works browsing directly to IIS, then the Reverse Proxy would need to help figure out why it isn't working.

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