Fisheye 2.7.8 Error When Connecting to JIRA


I just downloaded the Fisheye 2.7.8 free trial and installed on a Solaris 10 computer. In the Setup Wizard it asks for the url of our JIRA instance, the sysadmin login and password. After I enter these and click connect to JIRA, I get this fun error, I tried what it says but I still get the same error. Any ideas?

An error occurred: java.lang.LinkageError: JAXB 2.0 API is being loaded from the bootstrap classloader, but this RI (from jar:file:/export/home/fisheye/fecru-2.7.8/lib/jaxb-impl-2.1.10.jar!/com/sun/xml/bind/v2/model/impl/ModelBuilder.class) needs 2.1 API. Use the endorsed directory mechanism to place jaxb-api.jar in the bootstrap classloader. (See Please refer to the logs for details.

Thank you.


1 answer

Hi Sline.

I know this answer is opened for quite some time but this is probably caused by your Java version, it is JAXB 2.0 but fisheye requires JAXB21. Could you please try updating to the latest version of the Java Virtual Machine which contains the correct version of the library.

Douglas Fabretti
Atlassian Support

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

405 views 6 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot