Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,299,292
Community Members
 
Community Events
165
Community Groups

FishEye HTTPS / SSL Web Server --> No HTTP Bind

Deleted user Dec 20, 2011

Is it possible to deactivate the "normal" HTTP WebServer for FishEye? Actually my (HTTPS-) SSL-FishEye-Instance is running on port 8080 and the normal HTTP-Instance is running on port 6060. Because i don't need the "unsave" HTTP-Instance i would like to deactivate it. I have testet it through simply deleting the HTTP-Port in the FishEye-Configuration but after that i got some errors and couldn't log in to the administrator area. Here some snippets from the error-log:

2011-12-21 19:28:11,349 ERROR [btpool0-37 ] org.mortbay.log org.mortbay.log.Slf4jLog-warn - EXCEPTION 
java.lang.IllegalArgumentException: :///admin/admin.do
	at org.mortbay.jetty.HttpURI.parse2(HttpURI.java:166)
	at org.mortbay.jetty.HttpURI.parse(HttpURI.java:109)
	at org.mortbay.jetty.HttpURI.<init>(HttpURI.java:91)

4 answers

1 accepted

1 vote
Answer accepted
Daniel R Atlassian Team Dec 20, 2012

Hello osger,

Assuming you have already set up the SSL connector, try removing the XML tag for HTTP bind from your config.xml file directly:


<http bind=":6060"/>

Make sure to stop FishEye/Crucible before editing the config.xml file.

If that still doesn't work for you please open a support ticket at https://support.atlassian.com with the following data:

1. Go to Administration > Global Settings > Server > Debug Logging and Turn Debug Logging "ON".
2. Reproduce the problem.
3. Generate a Support Zip from the Administration menu (Administration >> System Settings >> Atlassian Support Tools >> Support Zip) and attach it to this ticket.

If you remove the entry from your config file by hand you will re-break your configuration every time you edit the server configuration to make a change as FishEye will write out the broken configuration file again.

I "solved" this problem on my end by giving the non-https bind configuration field a localhost value to bind to.

Was this every resolved? I'm having the same problem trying to disable HTTP.

0 votes
Chii Atlassian Team Dec 21, 2011

I believe you have hit this problem : https://jira.atlassian.com/browse/CRUC-4697

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

268 views 2 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you