It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

crowd upgrade on linux fails

Bruce Clegg Jun 23, 2014

We unsuccessfully attempted to upgrade crowd to 2.7.2

I feel like we followed the instructions carefully, and tailing the apache-tomcat.catalina.out log file, it shows it coming up (eventually) - but we cannot access on port 8080

I'm very new to Atlassian, so I'm not sure the best way to ask this question.

here is the server.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<Server port="8020" shutdown="SHUTDOWN">

<Service name="Catalina">

<Connector acceptCount="100" connectionTimeout="20000"
disableUploadTimeout="true" enableLookups="false"
maxHttpHeaderSize="8192" maxThreads="150"
minSpareThreads="25" port="8095" redirectPort="8080"
useBodyEncodingForURI="true" URIEncoding="UTF-8"/>

<Engine defaultHost="localhost" name="Catalina">
<Host appBase="webapps" autoDeploy="true" name="localhost" unpackWARs="true"/>
</Engine>

<!-- To connect to an external web server (typically Apache) -->
<!-- Define an AJP 1.3 Connector on port 8009 -->
<Connector port="8080"
redirectPort="8080"
enableLookups="false"
protocol="AJP/1.3"
scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS" SSLEnabled="true"
URIEncoding="UTF-8"
keystoreFile="/opt/data/aviva/ssl/.keystore" keystorePass="hmpssl" />

</Service>

<!-- Security listener. Documentation at /docs/config/listeners.html
<Listener className="org.apache.catalina.security.SecurityListener" />
-->
<!--APR library loader. Documentation at /docs/apr.html -->
<Listener className="org.apache.catalina.core.AprLifecycleListener" SSLEngine="on" />
<!--Initialize Jasper prior to webapps are loaded. Documentation at /docs/jasper-howto.html -->
<Listener className="org.apache.catalina.core.JasperListener" />
<!-- Prevent memory leaks due to use of particular java/javax APIs-->
<Listener className="org.apache.catalina.core.JreMemoryLeakPreventionListener" />
<Listener className="org.apache.catalina.mbeans.GlobalResourcesLifecycleListener" />
<Listener className="org.apache.catalina.core.ThreadLocalLeakPreventionListener" />

</Server>

What else can I show you that might help solve this?

4 answers

0 votes
Jobin Kuruvilla [Go2Group] Community Leader Jun 23, 2014

Is the port blocked on linux? Maybe stop iptables if it is running and check after that? Another thing is to check if selinux is enabled or not.

0 votes
Bruce Clegg Jun 23, 2014

Thank you for your quick response -

Port is not blocked - when we 'roll back' to the previous version (2.4 I think) by renaming the folder, we can get in just fine to that port.

0 votes
Jobin Kuruvilla [Go2Group] Community Leader Jun 23, 2014

Are you using a proxyName? What happens when you do wget on localhost:8080/crowd from the server itself?

0 votes
Bruce Clegg Jun 29, 2014

I've opened a ticket with Atlassian support on this - once there is a resolution, I will post it here. Possibly with a better description of the problem.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Published in Next-gen

Introducing subtasks for breaking down work in next-gen projects

Teams break work down in order to help simplify complex tasks. This is often done iteratively, with tasks being broken down into smaller tasks and so on until the work is accurately captured in well-...

977 views 12 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you