Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,458,180
Community Members
 
Community Events
176
Community Groups

crowd - apache http server authentication integration problem

Hi,

I would like to use crowd as authenticaiton backend server integrating with apache http server as http authenticaiton mechanishm. I've followed document below;

https://confluence.atlassian.com/display/CROWD/Integrating+Crowd+with+Apache

I'm getting this error;

[error] CrowdAuth: Failed to authenticate application.

- configuration;

<Directory "/var/www/">
  AuthName crowd
  AuthType Basic
  PerlAuthenHandler Apache::CrowdAuth
  PerlSetVar CrowdAppName XXX
  PerlSetVar CrowdAppPassword XXX
  PerlSetVar CrowdSOAPURL http://crowd.domain.com:8095/crowd/services/SecurityServer
  PerlSetVar CrowdCacheEnabled on
  PerlSetVar CrowdCacheLocation /tmp/CrowdAuth
  PerlSetVar CrowdCacheExpiry 300
  require valid-user
</Directory>

what did i check;

- application name and password correct, i also try with another application name and password it works with restfull api.

- i have checked remote ip configuration, i'm sure i added server's real external ip.

- i got tcpdump on the crowd server, it's below;

09:56:22.769876 IP xx.54627 > crowd.xxx.com.8095: Flags [P.], seq 2995895305:2995896539, ack 2611274641, win 281, options [nop,nop,TS val 254446793 ecr
 3787739752], length 1234
E...0.@.;...6H..
6"..c.....      ........+......
.*....RhPOST /crowd/services/SecurityServer HTTP/1.1
TE: deflate,gzip;q=0.3
Connection: TE, close
Accept: text/xml
Accept: multipart/*
Accept: application/soap
Host: crowd.domain.com:8095
User-Agent: SOAP::Lite/Perl/0.714
Content-Length: 933
Content-Type: text/xml; charset=utf-8
SOAPAction: ""
<?xml version="1.0" encoding="UTF-8"?>
<soap:Envelope
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema"
    soap:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
    xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
  <soap:Body>
    <namesp1:authenticateApplication xmlns:namesp1="urn:SecurityServer">
      <in0>
        <credential xmlns="http://authentication.integration.crowd.atlassian.com">
          <credential xsi:type="xsd:string">XXX</credential>
        </credential>
        <name xmlns="http://authentication.integration.crowd.atlassian.com" xsi:type="xsd:string">XXX</name>
        <validationFactors xmlns="http://authentication.integration.crowd.atlassian.com" xsi:nil="true" />
              </in0>
    </namesp1:authenticateApplication>
  </soap:Body>
</soap:Envelope>

- at the crowd server, the application is active.

- crowd url is correct, when i try with with curl, it works;

http://crowd.domain.com:8095/crowd/services/SecurityServer

[Invalid SOAP request.]

Could anyone help me to solve the problem.

Thanks.

1 answer

1 accepted

2 votes
Answer accepted

I see your Apache settings are a bit differente than the example in our site, have you tried with the example configuration in step 4?

<Directory "/var/mysite/">
.
.
.
  AuthName "Atlassian Crowd"
  AuthType Basic
  AuthBasicProvider crowd
 
  CrowdAppName myappname
  CrowdAppPassword mypassword
  CrowdURL http://localhost:8095/crowd/
 
  Require valid-user
.
.
.
</Directory>

Cheers

The configuration that you referred is for the 2.x version of Crowd-Apache Connector and it doesn't support ubuntu 12.04. As document says, i've used Crowd-Apache 1.4 Connector, documanted below;

https://confluence.atlassian.com/display/CROWD020/Integrating+Crowd+with+Apache

Am i wrong?


"This document is for the 2.x version of Crowd-Apache Connector, if you can't find an compatible version of the 2.x Subversion Connector for your O/S in the table below then refer to the 1.4 version of the Crowd-Apache Connector."

I'm pretty sure I've tested apache connector 2.0 with newer versions of Ubuntu, I believe our docs are outdated. I've opened this request to review this information: https://jira.atlassian.com/browse/CWD-3963

In the meantime, if you have a test server, you may want to test apache connector 2.0.

Cheers

Thank you Tiago. Using documentation i've easily configured 2.0.

Cheers.

I'm glad to hear that, if you thing this question was answered satisfactorily, you may accept the answer, this will increase its visibility and may help others in the future.

Cheers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events