Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,939
Community Members
 
Community Events
176
Community Groups

OpenID endpoint file includes wrong url without https

Hi, 

I would like to use OpenID together with Gerrit. All services are served via reverse proxy. 

When I access

 https://subdomain.mycompany.net/openidserver/op

following XML is produced

 

<?xml version="1.0" encoding="UTF-8"?>
<XRDS xmlns="xri://$xrds">
  <XRD xmlns="xri://$xrd*($v*2.0)">
    <Service>
      <Type>http://specs.openid.net/auth/2.0/server</Type>
      <URI>http://subdomain.mycompany.net/openidserver/op</URI>
    </Service>
  </XRD>
</XRDS>

The correct openidserver url should be https and not http

<?xml version="1.0" encoding="UTF-8"?>
<XRDS xmlns="xri://$xrds">
  <XRD xmlns="xri://$xrd*($v*2.0)">
    <Service>
      <Type>http://specs.openid.net/auth/2.0/server</Type>
      <URI>https://subdomain.mycompany.net/openidserver/op</URI>
    </Service>
  </XRD>
</XRDS>

 

 

As I know Gerrit use this information to perform the login. The base url in the openid server is already configurated to "https://subdomain.mycompany.net/openidserver/"

Is there any option to change the url which will be delivered by /openidserver/op? 

// Philipp 

1 answer

0 votes

I suspect you need to set the scheme in the Tomcat connector config to https - see https://tomcat.apache.org/tomcat-7.0-doc/config/http.html - as the OpenID server calls req.getRequestURL().toString() to populate the URI in the XRDS document, and from a brief skimming of the Tomcat source it appears that getRequestURL() delegates to getScheme(), which the scheme setting is documented as controlling.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events