Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

I am unable to connect to Microsoft active directory with crowd 3.4 Edited

Hi Folks,

I am unable to connect Microsoft AD with crowd.

Crowd Version : 3.4

Settings are as follows :

Connector : Microsoft Active Directory

Hostname : ldap.gslb.internal.xxx.com

Port : 636

SSL : None

 

Result : test failed

There was a problem communicating with LDAP server. ldap.gslb.internal.xxx.com:636;socket closed;nested exception is javax.naming.ServiceUnavailableException:ldap.gslb.internal.xxx.com:636;socket closed

==========================================

Able to ping Microsoft directory server (ldap.gslb.internal.xxx.com) from crowd server.

Is issue with LDAP or in Crowd?

Regards,

Amar

 

1 answer

1 accepted

0 votes
Answer accepted
Marcin Kempa Atlassian Team Dec 15, 2019

Hi @Amar 

It seems to me that you are trying to connect over LDAPS (secure ldap protocol, port number indicates that), however you've entered hostname as:

ldap.gslb.internal.xxx.com

What happens if you enter there: 

ldaps://ldap.gslb.internal.xxx.com

or

ldap.gslb.internal.xxx.com

but with SSL set to: LDAPS?

 

If that also does not work can you verify that AD is configured to use LDAPS and this port is visible for Crowd?

Are you able to connect on 389 non secure port using standard ldap protocol (ldap://ldap.gslb.internal.xxx.com)

In order to check if LDAPS is up and running on AD (Windows Server) side you can do:

  1. In Windows click on Start and search ldp.exe
  2. In ldap window select Connection menu and fill following parameters:
    1.  Server - this is your host name (I assume this would be `ldap.gslb.internal.xxx.com`)
    2. port: 636
    3. Select 'ssl' checkbox
  3. Click ok. You should see information about established connection

 

Let me know if that helps,

Best Regards,

Marcin Kempa

Thanks Marcin Kempa

it worked for me :)

Added below line in Hostname and set SSL :)

ldaps.gslb.internal.xxx.com

Thank Again

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

306 views 9 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you