Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Duplicate entry for key 'uk_token_id_hash' in crwod log

Hi,

I am wondering if anyone has noticed this error in crowd log. 

I am using latest crowd 2.7.2 and JIRA 6.3.6. I noticed that there are always some errors in crowd logs like:

2014-09-29 08:35:59,575 http-bio-8095-exec-21 WARN [engine.jdbc.spi.SqlExceptionHelper] SQL Error: 1062, SQLState: 23000
2014-09-29 08:35:59,575 http-bio-8095-exec-21 ERROR [engine.jdbc.spi.SqlExceptionHelper] Duplicate entry 'DExcfx0O9tpVuoIqjtqREw00' for key 'uk_token_id_hash'
2014-09-29 08:35:59,589 http-bio-8095-exec-21 ERROR [jdbc.batch.internal.BatchingBatch] HHH000315: Exception executing batch [could not perform addBatch]

 

so, what is wrong is my crowd and how to get rid of this error?

4 answers

i try to switch Token Storage to memory and error occurred. http://pastebin.com/Zub9B3wL

Hi, if you're running Crowd previous to version 2.7.2 it's possible that you're running into a bug as this one, in this case you may switch the token storage to in memory or upgrade Crowd to the latest version.

I hope it helps.

Cheers

i swither it to memory and error occurred. http://pastebin.com/Zub9B3wL

I am using crowd 2.7.2 build 626. the Authentication Token Storage is in database.

I tried to switch it to memory from web interface and error occurred can be seen from web interface and log.

http://pastebin.com/Zub9B3wL

Hi, since you're facing problem to switch the token storage via web interface, you can do it directly via database:

  1. Shutdown crowd - ensure the pid is stopped
  2. Perform a database backup
  3. Connect to the database
  4. Execute this sql:
    update cwd_property 
    set property_value='false'
    where property_name='database.token.storage.enabled';
  5. Restart Crowd
  6. Validate the session storage is now in-memory by Navigating to Administration > Session Config

 

0 votes

Would you please attach the full exception stack trace, e.g. on http://pastebin.com/ ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Taco Tuesday: Your favorite Trello blog takeaway

Hello friends! From the community that brought you Welcome Wednesday, Throwback Thursday and Friday Fun, welcome to Taco Tuesday, a weekly discussion about all things Trello. The best part? One Tac...

72 views 6 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you