Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crowd documentation not compliant with RFC6265

I've set up SSO according to the documentation with a top level domain (using domain.com for the example). However, this is not according to RFC6265 which Crowds tomcat appears to use internally. Giving me the following error:

2018-04-25 13:21:28,532 http-nio-8095-exec-6 ERROR [crowd.integration.springsecurity.AbstractCrowdSSOAuthenticationProcessingFilter] Unable to set Crowd SSO token
java.lang.IllegalArgumentException: An invalid domain [.domain.com] was specified for this cookie

 Is there any documentation on how to resolve this?

1 answer

1 vote
Bruno Vincent Community Leader Apr 25, 2018

Hi @SeanM2

You just need to remove the leading "." character from the SSO domain value in the General Options of your Crowd server. For instance domain.com instead of .domain.com

Alternatively you can override the cookie.domain property in the crowd.properties file of your application.

Will try that, thanks. Is there any way to ask Atlassian to change the documentation to reflect that?

Also, I'm using crowd 3.2 so the properties file won't help me unfortunately.

Bruno Vincent Community Leader Apr 26, 2018

You're right. I should have been more specific. Overriding the cookie.domain property in the crowd.properties file is actually an option for applications connecting to Crowd (including Crowd itself if version is < 3.0).

Bruno Vincent Community Leader Apr 26, 2018

BTW if you can't login to remove the leading "." character from the SSO domain value through Crowd's console, you can reset it directly in the database: https://confluence.atlassian.com/crowd/resetting-the-domain-cookie-value-97911346.html

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

181 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you