Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Crowd XML backup failed with NPE

We are currently evaluating Atlassian Crowd. When I tried to take a XML backup, a 'java.lang.NullPointerException' occured. (full stack trace: (crowd-error.txt) )

We have only one user in the crowd internal directory and no groups other than default crowd-administrators group. Also, we have one Windows Active DIrectory configured (connector - not delegated authentication).

Could you please help me to find the root cause for this?

3 answers

1 accepted

1 vote
Answer accepted

I tried to reproduce this with Crowd 2.7.1 (in use by you according to your stack trace) but wasn't able to. I used the embedded database and configured Crowd to have the internal directory plus an active directory connector.

Would you please tell me what database you have Crowd connected to, and if possible run the SQL select * from cwd_directory; on your Crowd database? That stack trace seems to indicate that the description for a directory is null, so I'd be interested to see if that is actually the case.

After clarification: Ah yep, Oracle would do the trick, and as you worked out you can fix it by setting a non-empty description. Looks like another occurrence of this old Oracle quirk; CWD-3216 would be appropriate to vote on if you'd like to see this fixed.

Other information:

  • No connected applications.
  • Active Directory connected with cache enabled.
  • This is just a basic instance.
  • Crowd version: 2.7

We use Oracle 11.2 . Descriptions for both directories were null.

Then I put descriptions for both, and then XML backup worked fine.

I think this is a bug in Crowd application. If description is supposed to be a required field, field validaiton must be done.

Please convert your comment to an answer so I can accept it. :)

Thank!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira Service Management

JSM June Challenge #2: Share how your business teams became ITSM rockstars

For JSM June Challenge #2, share how your non-technical teams like HR, legal, marketing, finance, and beyond started using Jira Service Management! Tell us: Did they ask to start using it or...

181 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you