Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,769
Community Members
 
Community Events
176
Community Groups

Could not able to Removing the 'crowd' Context from the Application URL

Hi All,

I could not able to Remove the /crowd context from the Application URL.

I thoroughly followed this CrowdKB. And failed bringing up the server.

404 error. 

My crowd version is 3.6.0.

Any ideas?

Thanks in advance.

3 answers

1 vote
Marcin Kempa Atlassian Team Jan 06, 2020

Hi @Teja 

Once you get everything sorted out, please make sure you follow 5th step of CrowdKB:

5. From <Crowd-Install>/apache-tomcat/conf/Catalina/localhost, remove the crowd.xml file to prevent Tomcat from loading the /crowd context.

 

Best Regards,

Marcin

1 vote
brbojorque Community Leader Jan 06, 2020

Hi @Teja ,

Changing server.xml and once started it won't start means that you improperly modified the file.

You should look into the logs and check what is the error, it could be that you forgot to close the tag or you've remove a text that you are not meant to remove.

@brbojorque and @Marcin Kempa Thank you very much for your response.

It really make me to check again the configurations and it worked.

I was just copying this below parameter below the <Host> tag in  the server.xml

<Context path="" docBase="../../crowd-webapp" debug="0">
                        <Manager pathname="" />
                  </Context>
            </Host>

 and did not realise <Host> tag has contain '/>' closing tag.

Regards

Tejas

Marcin Kempa Atlassian Team Jan 06, 2020

Thank you for the update @Teja !

Please make sure that step 5 I've mentioned is executed. If it is not, then you might be running two Crowd's applications at the same time on same Tomcat server. This might be causing some problems especially if you would like to go with Data Center.

 

Regards,

Marcin

Like Teja likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events