Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot Login With Jira or Confluence But Can With Bitbucket Edited

I am running Bitbucket, Confluence and Jira Server as Docker containers, all connecting to a Crowd server also as a Docker container.

I recently replaced the Crowd Docker Container, changing it from alvistack/Crowd to Atlassian/Crowd, ran a clean install and then imported my last Crowd backup.

I can log in to Crowd with my user, and can also do the same with Bitbucket.

However, I can't log in via Jira or Confluence. The application configuration in Crowd, and in the crowd.properties for both Jira and Confluence are unchanged and match. The URL to access Crowd is the same (https://crowd.domain.uk).

The Crowd API endpoint is at https://crowd.domain.uk/crowd/rest

I suspect that Jira and Confluence are trying to call the API at https://crowd.domain.uk/rest instead of /crowd/rest, but I have no way of knowing. Where would I change this to check that this is correct?

I have checked authentication of the user for each application within Crowd, and the authentication is successful. The issue appears to be with communicating with Crowd itself.

However, that atlassian-confluence.log displays the following. The jira-security.log is less detailed but also states: user.name tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.

2020-03-15 16:12:50,650 WARN [http-nio-8090-exec-13] [atlassian.seraph.auth.DefaultAuthenticator] login login : 'user.name' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
 -- referer: https://confluence.domain.uk/dologin.action | url: /dologin.action | traceId: 1996c261e88dda12
2020-03-15 16:12:50,845 INFO [http-nio-8090-exec-13] [confluence.security.login.DefaultLoginManager] recordLoginFailure
Failed login attempt for user 'user.name':
  Request URL: https://confluence.domain.uk/dologin.action
  User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0
  Remote Address: 172.18.0.1
  X-Forwarded-For: 192.168.1.3

 

 

1 answer

1 accepted

0 votes
Answer accepted

I was correct in realising that the crowd.properties file needed updating, to insert the crowd directory in the file structure:

application.name                      {application.name}
application.password                 {application.password}
application.login.url                   https://crowd.domain.uk/crowd/console/
crowd.server.url                        https://crowd.domain.uk/crowd/services/
crowd.base.url                          https://crowd.domain.uk/crowd/

 

previously the file was configured as:

application.name                        {application.name}
application.password                    {application.password}
application.login.url                   https://crowd.domain.uk/console/
crowd.server.url                        https://crowd.domain.uk/services/
crowd.base.url                          https://crowd.domain.uk/

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase

The benefits of using Jira in different departments

Jira is a great tool to use across different departments. Forget that paperwork – switch to Jira and get that tasks done smoothly. Marketing Jira allows for a complete digital transformation of you...

108 views 0 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you