Why doesn't the table sort?

This question is in reference to Atlassian Documentation: Tables

The online help says that you should be able to sort tables in view mode using the table headers. This isn't working on most of the tables in our space. Any ideas what's wrong?

5 answers

1 accepted

0 votes
Accepted answer

Just for funsies, click-drag select the data in a non-sorting table (or at least a few rows), then create a 1x1 cell table and paste.

I have found that sometimes imported tables don't function right, and this quick table recreation does the trick.

Yep, it worked. Thanks for the tip.

This didn't work for me. I've got some tables that used to sort, but no longer do so. Not sure if this is due to some change in Confluence, or some accidental side-effect of editing.

Removing the formatting and then recreating the first row as a table header did not help.

This behaviour turns out to be a browser issue. On a Mac (macOS 10.13.2) in Safari (with JavaScript enabled) I don't see the sortable table header, but in Opera I do.

This occurred to me as well when I had some rows that had multiple numbers on the same row, in the column I was trying to sort by. Example:

                                        Topic                                       | Value |
 this will sort well                                                        |  3         |
 as well as this row                                                     |  2         |
 but this will not                                                           |  4         |
 even if you want to keep these two together    |  2         |

It was of course fixed by separating the conflicting row to two rows.

It's been some time now, but as I recall, the problem went away when the row content was simple, as Rahav suggests. Thanks.

First things first, when you hover over a column head, do two little triangles appear?

There are a lot of ideas. But without any further information it is pure guessing.

Can you post some code or screenshots?

No, on the tables that don't sort, the two little triangles do not appear.

I usually work in the WYSIWYG editor, so the request for some code gave me an idea that perhaps the header row wasn't properly set on the table that doesn't sort. It wasn't, so I inserted a new row, made it the header, and deleted the old quasi-header row. It still doesn't sort, but the code looks the same to me as the code for the table that does have the little triangles and sorts. Here's the code for the beginning of the table that doesn't sort, including the header row:

      <th colspan="1">Writer</th>
      <th colspan="1">Scrum Teams</th>
      <th colspan="1">Subject Areas Covered</th>
      <th colspan="1">PDFs</th>

This table does have some empty cells in the first column. Could that be the problem?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Dec 18, 2018 in Confluence Cloud

Happy holidays from our team to yours!

Hi Community!  2018 was filled with changes for our team, both big and small, and we've taken a lot of time to both celebrate our wins and recognize areas of improvement. One thing that we're a...

484 views 3 18
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you