Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

When I published the Confluence with bitbucket repository URL, I get two issues. See details.

Hi Team, 

I am facing issue with confluence. I had created a confluence page and copied reference URL of my BitBucket repository and click Published. It successfully published the page, it was working perfectly fine but lately, I am getting two errors on the same page.

1. JIRA_Confluence_Error.JPG and When I checked the APIs, one of the API returning 400 status code refer this. JIRA_Confluence_API_Failed.JPG2. When I click on "connect to Preview", it lends on new tab with error JIRA_BitBucket_Error.JPG and when I check the cookies details, it says JIRA_BitBucket_CookiesError.JPG

Please note, Last week, this was working perfectly fine.

Thanks,

SD

1 answer

0 votes
Diego Atlassian Team Sep 03, 2020

Hello @Salin Doshi !

As I understand, we have a problem with the SameSite value that is set in the cookie not being sent with the request.

There a few questions that come to mind:

  1. What browser are you using when this happens?
  2. What version of the browser is it?
  3. Did you update the browser prior to this?
  4. Is this happening with other browsers?
  5. Are you still facing this behavior?

Recently, with Chrome 80 the default setting for SameSite was set as lax when not specified. This could be affecting the authentication.

I did check Bitbucket status as of today because this behavior has appeared in the past due to problems with the tokens. However, everything seems to be in working order:

Let us hear from you!

Hello @Diego ,

Hope you are doing well and safe!

 

There are the answers of your questions.

 

  • What browser are you using when this happens?
    • SD: I am using CHROME and FIREFOX and both have the issue.
  • What version of the browser is it?
    • SD: Chrome it is "Version 85.0.4183.83 (Official Build) (64-bit)" and Firefox it is, "80.0.1 (64-bit)".
  • Did you update the browser prior to this?
    • SD: It automatically updates by IT team.
  • Is this happening with other browsers?
    • Yes. Like I mentioned above, I have verified with Firefox.
  • Are you still facing this behavior?
    • Yes. It is same.

Please let me know if you need any additional details. Attached Firefox screen shot for same issue.

Firefox_sameIssue.JPG

Thanks,

SD

Hello @Diego 

Hope you are doing well.

I just found the solution of this problem. It is not a product issue, it is related to browser settings that my IT team has introduced lately so if I make the below changes, it works fine.

Sorry to bother you. Thank you for your time! We can close this loop. 

Thanks,

SD

JIRA_ChromeSettings.JPG

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

59 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you