Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unsupported Content Error Message

Hello! I'm getting an unsupported Content Error Message on a page I created. None of the pictures or content are there, and it is just the gray box that says the message. Any way I can find out what the specific problem is? Has anyone else run into this?

 

Dan

1 answer

0 votes

Hello Daniello,

Welcome to Atlassian Community!

I've searched for this error message and I found a bug, so I would like to confirm the steps you are following to confirm if it's indeed the bug.

After creating the page, what content are you adding on the page? Are you copying the information from external sources and posting them on the page?

 Please, check the bug for more details and let us know if that's the same issue you are facing:

Regards,
Angélica

Hey Angelica - I'm having the `unsupported content` error on 2 of my pages that were working before the new year - nothing has been edited between them working and not. 

Based on the linked issue, I believe there's more going on - the pages in question have no content-based from a 3rd party source apart from screenshots pasted in. 

As you can imagine, as a product team, without access to documentation that is reliable is causing a bit of a hiccup in our operations! Can you let me know what information you need to resolve this as soon as possible?

Thanks!

Hello Kendra,

Welcome to Atlassian Community!

Thanks for reporting this issue to us. I searched for bugs related to Unsupported content and images only but didn't find anything, so we need more information to test here.

Is this issue happening when pasting a screenshot or also when uploading some images?

Are you adding the images inside some macro, like expand, columns, tables?

Is this happening with any type of image or just a specific extension?

Regards,
Angélica

Hey Angelica, thanks for searching! 

 

Great questions - There's two pages that it seems to be occurring, both of which have:

- Layout usage (mostly 3 column)

- Emojis (sometimes added via the macOS shortcut of control+command+space to bring up the emoji keyboard, other times added via the `:` shortcut Atlassian added)

- Screenshots

    - Pasted in directly

    - Added inside `/expand` macros

- `/expand` macros (multiple)

- The new 'status' bar with the new editor

- General text styling like links, headers, check box lists, bolding, etc. 

- `/jira` macro

 

I'm not comfortable pasting the screenshot of the page in edit mode to the community, but can certainly email directly somewhere if you'd like to have a look! The only third party content I see are screenshots added to expand macros. 

I don't use any extensions for screenshots, just the mac keyboard shortcut to grab part of the screen and the good 'ol fashioned paste! 

I had the console open when clicking onto the page (where the unsupported content appears) and then when clicking into edit. In the attached image, the errors/warnings appeared only when going into edit mode. Maybe it'll give the team a clue as to what in those pages might be the culprit I can remove?

errors.png

Hope this helps debug! Let me know if I can provide any other details :) 

Thank you for the details, Kendra.

I tried to replicate the issue on my local site, but using images inside the expand, status, layout, Jira macro and when I publish the page, everything appears correctly. I tested using an empty page and not a template.

Searching for similar issues related to the error we see in the console, there are many things that can cause this, so I’m going to ask other questions and then if we can’t identify the cause, we will need a ticket with our support, so they can access your site and also it will be easy to check the logs.

On the affected pages, are you using a macro inside another macro? 

If you copy/paste the same content to an empty page, does the issue happens?

Also, do you remember if before the issue happens, if it was the old editor? I’m asking because on some sites the pages created on the old editor are being migrated to the new one.

Hmm! I wonder if it's template related - both pages were originally created as a template, using the new editor experience (neither touched the old version). 

 

The only macro-in-macro combo is a `/jira` inside a `/expand`, but this is working just fine on other pages.

The two trouble pages were working before the holidays, and no content on them was changed between then and it showing unsupported content errors. Because they were working just fine before, I don't think it's content-related.

The workaround of creating a new page concerns me as there's a lot of links in/out that would need to be sourced and redone, and likely there's a bug here as no edits were done to the page during the time it started working. I'd worry the root cause would surface again and I'd have spent time on a redo for nothing. 

Is there any way to escalate to a support issue on your end so they access the logs so I don't have to bother our executive team to create an admin-ticket for this?

Thank you for the details again, Kendra.

There is a bug related to templates that affect the "Decision Log" template only, but I believe that's not your case.

We can create a ticket on the admin's behalf and add you as a participant. I see that there are four admins,  so just let me know the first name of one of them that I can use the email to create the ticket and then you just let them know about the notifications they will receive.

As a participant, you will receive all notifications and will be able to interact with the support engineer.

Hey Angelica, thanks for your help here!  

One of our admins is Dave Russell. Let me know if there's anything else you need :) And again thanks for the help!

 

-Kendra

Thank you, Kendra.

I created the ticket on Dave’s behalf and added you as a participant.

You should have received a notification and if not, you can access the ticket directly from the portal:

I won’t be the assignee, but I’m watching the ticket, so if you don’t receive updates or have any other questions, please let me know.

Hey Angelica! 

 

Figured I'd close the loop for any curious eyes browsing the forums - turns out the issue was nested bullets within a macro - 2nd+ layered bullets aren't supported yet. In addition, there was also issues with certain strings of text that use symbols in JIRA issue titles that when nested in the macro through a JIRA macro, caused a section to freeze, therefore not properly show. 

I've stayed away from nested JIRA macros / 2nd layer bullets and we're back on track!

Like # people like this

Hello Kendra,

Thank so much for sharing. It will definitely help other community members that may face the same issue.

Hope you have a good day!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

Table Row Highlighter - CSS Hack

(Said in an infomercial voice) Has this ever happened to you? You are on a Zoom/Teams call, looking at a large table, and people are confused where on the table you are pointing (insert video of real...

194 views 0 2
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you