UPM says plugins are up to date, they're not

Hi,

I did an upgrade of our confluence (3.5.9 on test environment) and wanted to update the plugins. But the UPM says that all the plugins are already up to date. But they're not. For example, ThemeBuilder was still 4.0.4 and not 4.2.2, UPM it self was also an out dated version. Still, the 'Upgrade' tab is empty.

However, if I check the 'Install' tab, the UPM is able to get a list of plugins from https://plugins.atlassian.com/.

So, the UPM can reach internet, nothing appears in the log files, but Upgrade list is empty.

Any idea?

Regards, Thomas

2 answers

1 accepted

Accepted Answer
0 votes

Never mind, for some unknown reason it works again after several restarts of Confluence :).

Edit: but not for all the plugins. I did some random checks and I found at least two plugins that are not up to date.

0 votes
Ben Woskow Atlassian Team Mar 27, 2012

UPM will only display updates that are compatible with your current product version. It is very possibly that even though there were new plugin versions on the Plugin Exchange, that those new versions were not marked as being compatible with your Confluence version.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

320 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you