Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Swagger API not showing for users without account on Confluence

Gabriel Domingos de Oliveira
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 15, 2024

Hello guys, I'm having a bit of problem when trying to upload my API Documentation on Confluence.

Using the Swagger Macro and a attachment with a .yml file, I'm able to display my documentation on a Confluence Page. However, when sending the newly created page to someone that doesnt have a Confluence login ( or accessing on anonymous tab ), I am able to see the page but where is supposed to show the Swagger Doc, it shows only a message saying that "You dont have permission".
I already made both the Space and Page public, but still with the same problem.

Does anyone know any workaround to this?

confluence-404.png

1 answer

1 accepted

1 vote
Answer accepted
marc -Collabello--Phase Locked-
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
February 16, 2024

Hi @Gabriel Domingos de Oliveira ,

This is by design.  Atlassian writes at https://support.atlassian.com/confluence-cloud/docs/how-secure-are-public-links/ that third party macros are hidden.

 

Gabriel Domingos de Oliveira
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
February 16, 2024

Hi marc, just read it on the link you sent. 
Now I can move on to the next option to public my APIs.
Thank you so much!

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS
AUG Leaders

Atlassian Community Events