It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Stop auto column width adjustment

I am trying to create a table where the first cell of each row has a Jira Issue Filter macro. When that macro is created to display as a table of values, its width grows and pushes the enclosing column width way out wider than the page.

Is there a way to stop the table from auto sizing the column widths?

And, even when I try to drag the column width back to a sane width, often the table just autosizes the column again.

 

Any help appreciated.

2 answers

0 votes

Hi @Bernard_Puc

I tested this in our test instance and it doesn't do this for me in the new editor - just in the classic editor (which is being decommissioned at present).

To fix this on the classic editor:

  1. Edit the page and click on the table
  2. From the table options which appear on the top navigation bar, change the drop-down on the left-hand side from "Responsive" to "Fixed Width"
  3. Press Publish

^ This will stop the table from changing the size of the column, allowing you to scroll left-to-right to see the full contents of a Jira Filter Macro if it doesn't fit within the column's width.

This happens by default in the new editor - if this isn't happening for you, send us a screenshot of your current setup :)

Ste

Hi Stephen, thanks for your response.

First, I think that I have the new editor. Whatever the default is when a new blank page is created? In my experience, there used to be a table options navigation bar at the top of the screen where you would insert/delete rows/columns etc. - that nav bar no longer appears. I have attached a screen shot of my page, in edit mode, with the table selected. The only table options i can find are the ones you get when you click the little arrow inside a cell, and the one at the bottom of the table which has just three options.

tablesnip.PNG

Hi @Bernard_Puc

Yep this is the new editor - but it appears to work as you need it to in our version.

Does it still stretch the page in published mode as opposed to edit mode? On our instance it doesn't always look as clean in edit mode as published.

Ste

Ultimately, when I publish, the column width remains where I last put it, in edit mode. That's fine. The problem I was trying to address was the fact that while editing, the column width is automatically adjusted every time I add or edit a Jira Issue macro. Since I am adding a Jira Filter macro in the first cell of every row, then moving on to the next cell in the row, it is very annoying to have to resize the column every time. So, just wondering if there was a way to disable that resizing from happening.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,550 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you