Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


NEED HELP Suddenly Got " isShowSignUp in LoginAction for Application NullPointerException"

hello guys I really need your help on this :

 Invocation of method 'isShowSignUp' in class com.atlassian.confluence.user.actions.LoginAction

threw exception java.lang.NullPointerException: Application cannot be null at /login.vm[line 6, column 28]

    Application cannot be null

it was not during a backup time or return system proc,  

the confluence suddenly got the problem. 

how can we solve it ?

My team would greatly appreciate your help  :) @Shannon S  @Brant Schroeder  




Method I tried with my team so far: 

my cwd_app_dir_mapping's index is correct  as 0,1 Asc



I got unempty cwd_app_dir_mapping and 

  • cwd_app_dir_group_mapping             
  • cwd_app_dir_mapping                   
  • cwd_app_dir_operation 

4 answers

My tables are also empty.  I've had to restore my DB from backup... It worked fine for a couple of days, and then it happened again!

Now no available solution we too  restore my DB from backup... 


However the character in content and. BodyContent have been ? instead of original Chinese words. 


Trying to fix it....


Please keep us updated ! hope everything is fine for both our confluence

Like John Stafford likes this

I tried using the suggested sql statement on my MS SQL server, and it says the statement is wrong. What am I doing wrong?

I tried the following statement:

UPDATE cwd_app_dir_mapping
WHERE ID=<first_id>;

Yes to use the statement the other answer give us, we should replace the 


 with our own id , 


You can do following steps:


to connect to your database and look for the id by :

SELECT * FROM cwd_app_dir_mapping;

 and you will see the id (e.g. 1200000)



Then conduct the sql: 

UPDATE cwd_app_dir_mapping
WHERE ID=1200000;




And if you have more than one rows,

just repeat the update sql until you get  the list_index of the directories are in proper incremental order (i.e., 0, 1, 2, ...)


UPDATE cwd_app_dir_mapping
WHERE ID= 1200000;

UPDATE cwd_app_dir_mapping
WHERE ID=12000001;

UPDATE cwd_app_dir_mapping
WHERE ID=12000002;


Perhaps, it's strange, but my  cwd_app_dir_mapping table is empty. It doesn't have any data.

I started getting this error only yesterday, just like you

In fact, all of the following tables 

  • cwd_app_dir_group_mapping             
  • cwd_app_dir_mapping                   
  • cwd_app_dir_operation 

are empy

It seems that yesterday during searching I have encountered the QA for empty tables, you can search for it. Mostly it happens during back up/return system for  your situation

Thank you!

I followed the instructions provided, I was able to create the admin/admin account.

But now all of the spaces are gone and I don't know how to recover them

In this case , you can check your back-up

and found the last one with biggest usage (40kb,43kb,50M)

and restore the 50M back-up


I dont think you deleted them if you didnt run such command, so they must be here

0 votes
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
Nov 06, 2023


It suddenly happened to us yesterday in the evening 


昨天北京时间傍晚左右忽然出现的,也不是备份或者回退系统的时候,网上的方法  用了但是没用


 reboot and ./ & ./ could not solve the problem

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events