Linux-confluence installer (.bin file) error : Syntax error: "(" unexpected

I download the confluence installer, atlassian-confluence-4.2.13-x64.bin,

I changed it to executable with >chmod 777 atlassian-confluence-4.2.13-x64.bin,

and when I run it with > ./atlassian-confluence-4.2.13-x64.bin, I get the following error:

Unpacking JRE ...
Starting Installer ...
/mnt/archive/atlassian-confluence-4.2.13-x64.bin.1646.dir/jre/bin/java: 1: Syntax error: "(" unexpected

What is wrong, and How can I fix it?

Thanks for answers

4 answers

This widget could not be displayed.

I'm seeing the same problem with the latest 4.3.3 build on ubuntu: /home/ubuntu/atlassian-confluence-4.3.3-x64.bin.5105.dir/jre/bin/java: 1: /home/ubuntu/atlassian-confluence-4.3.3-x64.bin.5105.dir/jre/bin/java: Syntax error: "(" unexpected

This widget could not be displayed.

Hi Bahar,

To be honest with you, you're doing everything right.
Can you try to download Confluence 4.2.13 again from our website: http://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-4.2.13-x64.bin ? That file could be corrupt.

I hope this helps.

Regards,

WZ

This is where I downloaded confluence :)

Also, I installed confluence using the same bin file on a different machine.

This widget could not be displayed.

Hi Bahar,

As an alternative approach I would suggest you to try to install Confluence using the tar.gz file, that you can download from this link below:

http://www.atlassian.com/en/software/confluence/post-download?file=http://www.atlassian.com/software/confluence/downloads/binary/atlassian-confluence-4.2.13.tar.gz

And then try to follow these instructions to install, it's easy as the installer, no worries:

https://confluence.atlassian.com/display/CONF42/Installing+Confluence+on+Linux+from+Archive+File

If you still experience problems with your install after this attempt, please feel free to raise a support ticket at our support.atlassian.com and we will be glad to take a look at this problem with you in order to solve it.

I hope this helps.

Cheers,

LJ.

This widget could not be displayed.
Once i had this error. I found out i downloaded the installer for the wrong architecure. Check if the installer matches your hosts arch. 32/64 bit

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

364 views 2 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you