Links to on-page anchors migrated (2.8 to 4.3) as #name

After migrating to 4.3 (from 2.8 via 3.5.17) we find that links of the form #NameOfAnchorOnPage are displayed with the leading #.

eg: #NameOfAnchorOnPage now shows as #NameOfAnchorOnPage instead of NameOfAnchorOnPage

and View Storage Format shows it as

<ac:link ac:anchor="NameOfAnchorOnPage"><ac:link-body>#NameOfAnchorOnPage</ac:link-body></ac:link>

FYI: We have had many other problems on the way, many being/been dealt with by Josua Masikome.

1 answer

1 accepted

Hi Peter

I believe this behavior is a bug as you can see here: CONF-25882

You'll be able to find the workaround on the link above.

Cheers!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,089 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you