Links to headings or anchors within same page does not work in html export

I have a page with 2-3 subheadings. One of the headings is

Test Heading

Now, if I create a link to this heading using Insert Link > Advanced with link = #Test Heading, the link works in wiki. But if I export html, the link doesn't work in the output.

We are using confluence version 4.2.2 in production but we have tested it in 4.3 as well.

1 answer

I have added to the bug fix on the jira page above. I can be fixed.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

370 views 20 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you