I've attached a .graphml (yEd xml file) to a page, but its extension gets changed to .bin on download

The .bin file has the correct contents.

I've tried altering the Content Type to application/x-upload-data, text/xml, application/graphml+xml but none of these changes anything, it's still .bin when downloading.

1 answer

0 votes
Jason Worley Atlassian Team Jan 04, 2014

I wasn't able to reproduce this. Can you try it with another browser? I found this issue for example:

http://support.mozilla.org/en-US/questions/840257 (not sure if you might be running an older version, etc).

I just tried with two different browsers:

chrome Version 31.0.1650.63 (Linux) This one has the problem (editting a page, insert .graphml attachment, downloads as .bin file).

Firefox 26.0 (Linux) behaves somewhat differently. It asks me:

You have chosen to open:

file.graphml

which is: BIN file (167 KB)

Would you like to save this file?

If I click yes, I get the correct file with the correct extension

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Mar 12, 2019 in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

292 views 2 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you