Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do you disable page comments but keep inline comments enabled?

Inline comments are great because you can discuss an issue and then resolve it.

Page comments (the ones at the bottom of the page) can't be resolved, so they are just always visible, even if they have been fully resolve.

For one of my spaces I want to prohibit the use of page comments but enable (and encourage) inline comments.

I can't work out how to do this.  I can only disable/enable page and inline comments together.

Thanks in advance.

2 answers

1 accepted

5 votes
Answer accepted

One option would be to go to the space for which you want to hide the comments, then click on Space Tools, Layout, Stylesheet, and then add the following line:

#comments-section { display:none; }
Bill Bailey Community Leader Mar 13, 2018

Love a white tape approach! ;-)

This works just fine for me.  Thanks very much :-)

As a follow up question.  Do you know how I can disable comments on a single page (rather than a whole space), but still keep inline comments enabled?  I also have a need for this.

My suggestion would be to create a user macro with the following content:

## @noparams
<style>#comments-section { display:none; }</style>

Make sure that it's visible only for Confluence Administrators, call it something like "Disable Page Comments", key like "disable-page-comments", and then insert it into the page(s) for which you want to disable page comments.

Where do I find Space Tools > Layout > Stylesheet? I don't seem to have these options available. Is this a restriction issue perhaps?

 

[5b38c25225dbe580c6f8ac414416b093]_Image 2019-02-18 at 3.49.34 PM.png

Bill Bailey Community Leader Feb 18, 2019

Under the Look and Feel tab.

Yup went there and there is no regular Stylesheet. There is one for PDF Export Stylesheet which is not relevant.

Screenshot:

https://cl.ly/4fa81b7313cd

 

I think I just might have a different version of Confluence :(

@Bill Bailey any idea? Do you think it has to do with different versions of Confluence?

Bill Bailey Community Leader Feb 26, 2019

Well the screenshot you added shows the Look and Feel tab. Is non-functional? What version are you using?

This is what I see:

 

Image 2019-02-19 at 9.10.22 AM.pngNo idea which version I am on.

Bill Bailey Community Leader Feb 27, 2019

OK, you don't have enough permissions. According to the latest docs:


Note: By default, only system administrators can edit the CSS for a space or for the site. To allow any user with Space Admin permissions to edit the CSS for a space, go to > General Configuration > Security Configuration and select Custom Stylesheets for Spaces.

styling-confluence-with-css


So at a min, you need to be a Space admin and have the sys admin enable the permission.

You can find your Confluence version is typically displayed at the bottom of the page (above the Atlassian logo).

This doesn't work on the cloud hosted version :-(

https://support.atlassian.com/confluence-cloud/docs/functional-differences-in-confluence-cloud-vs-server/

> On Atlassian Cloud, Confluence uses a custom theme that can't be modified or updated using custom HTML or CSS.

 

Any workarounds here?

There is no out of the box functionality that allows you to disable comments while enabling inline comments.  Unfortunately comments and inline comments are all under one permission "add comment".

This plugin allows disabling comments on certain pages, but I'm not sure about inline comments:  https://marketplace.atlassian.com/plugins/de.scandio.confluence.plugins.hideelements-macro/server/overview?_ga=2.167233470.1408681685.1520821806-2024476247.1511688550

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

🥓🙅🏻‍♀️ Meet-less May Badge!

Hello Confluence Community!  What if i told you that you could have a healthier life and be 100% meet-less? This month, we're promoting a healthy, balanced work diet with Confluence. We la...

195 views 2 13
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you