File fields format for CLI plugin removeUsersWithFile

Does anyone know what the file format is supposed to be to use the removeUsersWithFile option in the CLI Plugin. Don't tell me a csv, because I already know that part. I have a file that works perfectly with the addUsersWithFile, but it failes everytime on the remove. I've tried using just the user names, I've tried username,password,email,full name. I've search the cli plugin page. Lots of examples of the commands, but nothing to tell me what fields it wants in the file. I'm sure that I have seen an example of a file once before, but I don't seem to be able to find it now.

Has anything tried this option before?

3 answers

Hello,

the question is a bit old , but I am posting an answer for the convenience of whoever stumbles on this problem =)

 

Had the same situation :

  • removing # of users with a file
  • got error in the process : "Client error: Error reading file: local_users_to_remove"

The problem is not the file you are working with, it is the error message!

What actually happens is that the user cannot be removed (is assigned to an issue, is a reporter or commented), nothing wrong with reading the file.

So you have to deactivate the user. Another word of warning there,  the email-address of the user has to be a valid format (often not the case when importing users in a migration).

If this is not the case , you will get a positive reply from JIRA CLI saying the user is inactive , when in fact the user is still active. You will have to use something like this:

$atlcli $instance --action updateUser --deactivate --userId YOURUSERID --userEmail YOURUSERID@makeitvalid.com

 

hope this helps someone...

 

best regards,

Loïc

Created JCLI-573 to cover this.

Same file should work. Actually, it just needs the id as the first column in the csv file (no header line) as all the other information on the same line is ignored. Create an issue if this is not working.

thats what I thought, but it is complaining about the file, "error reading file". I've verified that it is a real, valid csv file. And it works with the addusers so it should be in the right format. Its got me slightly baffeled.

never got this to work, but came up with a method that didn't involve using this feature so it all worked out in the end.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,831 views 27 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you