Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Failed to load batch.css after stuck thread Edited

During installation of Confluence 7.2, the server hangs during the setup of the database schema and ends up with a stuck thread. Once the stuck thread recovers and I refresh the page, the batch.css file fails with a 500 error. If I go to the path of the batch.css file, the page says that the container was not started. There are two batch.css files that this happens on: one for the generic style and the other for the setup style.

The server I am running on has 4gb of ram and 3 cpu cores. I've attached the log for Confluence and the stacktrace on the batch.css file.

 

Confluence log

batch.css stacktrace

 

2 answers

1 accepted

0 votes
Answer accepted

So it turns out that the problem was not with the amount of RAM or timeouts occurring during the setup. I was accessing the Confluence from behind Cloudflare which automatically caches pages, including the generated `batch.css` and `batch.js` files. By adding a page rule to bypass caching for the application, it fixed everything.

Thanks for trying to help with debugging @brbojorque 

0 votes

In the log it says it stuck, I would suggest to increase the memory allocation.

4GB RAM is a bit low, remember by default Confluence will use 2GB max and 1GB for synchrony.

--

 

Would it be possible to disable synchrony overall and run with 4gb of ram, or would I need to do some other tuning? I am only hosting this for 5 users, so I would like to be able to use as few resources as possible.

brbojorque Community Leader Dec 22, 2019

Hi @akrantz ,

Try to decrease the JVM from 2GB to 1GB and try to start it again.

And in your DB please make sure it can handle the DB schema creation.

Use postgresql and optimize the connection.

@brbojorque

I am currently using postgresql, but I'm not sure how to optimize the connect. Do you have any advice?

brbojorque Community Leader Dec 23, 2019

@akrantz 

Just redo the DB setup until the Postgres Db is completely done with the schema creation.

I'm sure your PSQL is fine.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What do you think is the most *delightful* Confluence feature? Comment for a prize!

- Create your own custom emoji 🔥 - "Shake for Feedback" on mobile 📱 - An endless supply of GIFs via GIPHY 🤩 Is there anything quite as nice as a pleasant surprise? Comment below with what...

415 views 23 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you