It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error 'there was an issue processing the request' when trying to publish updates on a page

Hi, I am getting this error message when I am trying to publish updates on an existing page. Not on all my confluence page but on one specifically.

Even though I created the content on another page (text only) I also got this error after a while using and updating its content.

I can save it but can't publish it... so frustrating.

Any root cause or solution for this?

10 answers

I'm getting the same thing. Some pages are fine, but for one particular one I cannot publish it.

Same here, just one Article.

I have the same problem, only on one page...

Saw a similar discussion about this here: https://community.atlassian.com/t5/Confluence-questions/Getting-error-quot-Unable-to-communicate-with-server-Saving-is/qaq-p/27058

But those solutions didn't help. In my case i have no browser plugins and "%"- Signs work just fine. 

We ran into the same issue recently. We think it has something to do with one of the many tables on the page. This is what I did to fix it.

I copied the page to another space. Note, it copied the version without the change we were trying to make.

I made the changes and saved the new page.

I deleted the content on the original page.

I then copied the source code from the new page to the old page and was able to save it.

We still haven't figured out what the issue is/was.  We are using the server version of Confluence.

Our page also had several tables.

We raised this as an issue with Atlassian but it never really got anywhere. It was left that we would contact them if it happened again. It hasn't yet! So I guess it is a fairly obscure bug.

Like # people like this

we're just moving back to google sheets. seems like google is the only company making products that work nowdays.

I have the same issue with just one page. I click Publish and get this:

Error message when publishing a page.PNG

We are using Confluence server edition version 6.2.0.

Just out of interest, which version are you using?

I am going to submit this as a support request.

I removed @ mentions which were linked to deleted accounts and then I could publish changes.  Additionally, I am going to try the below prior to deleting any account with published Confluence content:

https://confluence.atlassian.com/confkb/how-to-change-the-creator-of-a-page-720830744.html

Hi Timothy,

I was the creator of the page that we had this error occur. We didn't have any mentions on the page. We have determined it has something to do with the multiple tables and maybe text boxes, in our case. We haven't spent any time trying to troubleshoot as it has only happened twice on two different pages in the same space. Glad you were able to correct your issue!

The issue went away for me when I removed snippets of HTML web pages I copied and pasted into Confluence. I'm thinking there's bad HTML or confusing HTML that Confluence does not like causing the timeout and error message. I will need to copy & paste as plain text going forward, or find a better way to include snippets from random web pages.

Had this error as well. I am not sure what is causing it, but I found a workaround.

Cut all content in the page (so it's on your clipboard, but is deleted). Then save the page. You should be able to save the page now. Then edit it again and paste the content here again. You should be able to update the page now without it throwing an error.

I came across the same issue. It seems to be the mention @ in the document. If a user is added to Jira/Confluence and they have not registered or logged in and if you mention that user on the document, you will get this error.

I had the same issue. For me it was an 'info macro' that prevented me from publishing a document. After removing the info section, I was able to publish.

I had this same error many times today with just one page. I copied many HTML tables from an HTML page and pasted into this page.

The way that I was able to work around the issue was by pasting in only half of the tables at a time and publishing the page after each of the two paste actions.

Had a similar problem using the new editor in Confluence Cloud before publishing for the first time a copy of an existing page (that I had renamed and moved to a different space beforehand).

I clicked "Close" on the page draft then navigated to my Recent work > Drafts : To my surprise, a page named "Untitled" was showing (rather than with the name I had given it).

I opened this unnamed draft and indeed the title I had previously typed was gone! I retyped the page title and voilà, I was able to publish the page just fine!

Hope this helps someone...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,393 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you