Error importing Word DOCX file

Hi,

On Confluence v5.5.2. When I try to import a Word DOCX file via Office Connector, I see the following error:

 

The following error(s) occurred:

 

  • The selected file is not a valid binary Word 97-2003 document


From what I understand, this issue was fixed in v3.1.


Can anyone suggest a workaround or other resolution? Thanks!

Steve

 

4 answers

Stephen,

Are you by chance using office 2013?

This may help: https://confluence.atlassian.com/conf52/editing-an-office-presentation-from-confluence-401441748.html

CONFIGURATION MATRIX

You need one of the following software combinations to edit Office files from your wiki page:

Operating System

Office Version

Browser

  • Windows 7,
  • Windows Vista, or
  • Windows XP with Service Pack 2 or 3
  • OpenOffice 2.x – 3.x, or
  • Microsoft Office XP, 2003, 2007 or 2010
  • Internet Explorer 8.x – 9.x, or
  • Firefox – latest stable version
  • Mac OS X 10.5 and 10.6
  • Firefox – latest stable version
  • Linux
  • OpenOffice 2.x – 3.x 
    The only known supported Office editor for Linux is OpenOffice. But in theory it should work with any WebDAV-aware application.
  • Firefox – latest stable version

 

 

Stephen S,

Thank you for your quick response!

I have

  • Office 2016
  • Windows 10
  • Chrome browser

Seems that the above table is outdated as it goes only up to Win7 and does not mention Chrome...or...is Chrome not supported?

 

 

 

Correction:

Chrome is supported as far as confluence, but your version of office is not. And the version of office may be where your problem is.

 

Chrome does NOT support the built in edit function of office applications. Only IE and Firefox will support that within windows.

Hi, Sorry for the delayed response...I was locked out from posting more for a while, unless I earned points.

Two follow-ups:

  1. Please clarify what you mean by "the built-in edit function of Office applications."
  2. Are you saying that Word DOCX files created with Word 2016 do not work, while docs created with 2013 do work? Does the document header contain the Word version#?

Thanks.

 

Stephen,

Please reference my note below for supported office applications and your version of confluence.

Thanks!

Glad I could help, if the answer below is correct please mark it so.

Answers marked correct help others when asking the same question.

Thanks!

Let me get back to you. On a tight deadline this evening. Btw I mis-stated my version it was 5.4.3. Thanks.

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,551 views 25 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you