Editing a Confluence Page does not work

Hi,

I recently went through a laborious upgrade and succeeded upgrading Confluence 3.5.13 to 5.1.2. This was an incremental upgrade as advised in the documentation.

Happily, everything works and my Confluence is setup to work with our crowd server.

My only problem is editing a page. When I click on the Edit button inside a page, the redirection takes some time and goes to http://<OUR-DOMAIN>/pages/undefined (Page Not Found).

What is awkward is that if I RIGHT-CLICK on the Edit button and paste the url (<OUR-DOMAIN>/pages/editpage.action?pageId=<9999999>, I go to the editor and everything is great. I can also edit this url: <OUR-DOMAIN>/pages/viewpage.action?pageId=<9999999> and replace 'view' by 'edit' and it still works. CTRL-CLICK-ing (opening in a new window) on the Edit button is also OK.

I looked at my confluence logs, there are no logging when I get redirected to http://<OUR-DOMAIN>/pages/undefined.

I looked at my network monitor and notices that there are google analytics http requests before this error but I doubt

this has anything to do with it.

Any help is greatly appreciated, I spent a lot of time trying to fix it but had no luck.

Cheers.

4 answers

1 accepted

Hey there,

It's not a bug. Another customer had the same problem, and for them, it turns out to be a google analytics script in their Confluence Admin >> Custom HTML . Removing it fixed the issue. For some, the script might be in a custom layout in Confluence Admin >> Layouts. Changing the theme to Documentation theme resets these customizations, which is why it worked.

Foogie

We had the same issue! It turns out our tracking code script was out of date. Once we copied over the new script, it worked! Here is the guide on how to get the Google Tracking Code https://support.google.com/analytics/answer/1008080?hl=en. Hopefully that will work for some of you!

Thanks Ramiro, I tried the re-indexing but no luck. In the Network monitor output I see this error:

AJS.Rte.getEditor() is null

After some Google-ing most people identify the Play SQL plugin to be the cause of the above error but I don't have it! Besides, if the error was in the indexing, pasting the proper 'editpage' url would still not work which it does in my case.

Strangly, the problem seems to be related to the "Global Look and Feel" theme!! In our case, changing the theme from the above to "Documentation Theme" solves the problem; you can click on the Edit button and the page becomes editable.

Thanks again for the reponse.

The error in Chrome is the following:

Uncaught TypeError: Cannot call method 'setDirty' of null
AJS.Rte.Content.editorResetContentChanged
AJS.Rte.BootstrapManager.initialise
(anonymous function)

I have no idea how to resolve this problem and changing the theme of all our pages is not acceptable!

I hope somebody has a solution forn this annoying bug.

Thanks

Hi Foogie Sim,I'm facing the same javascript bug like kazoompa on newly instaled Confluence without any customisation. I can't create or edit any page. My second error appears when I click on root "Pages", when I get "java.lang.RuntimeException: Error rendering template for decorator root
at com.atlassian.confluence.setup.velocity.ApplyDecoratorDirective.render(ApplyDecoratorDirective.java:186)"
Thanks in advance for your help,Ondrej

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

942 views 23 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you