It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Draw.io plugin issue - Error saving file / Diagram is edited in another session Edited

Since Friday, I cannot use Draw.io plugin to edit my diagrams. 

First time it says: "Error saving file"

Then, after pressing "save and exit" a second time, it says : "Diagram is edited in another session. It will be saved as a new attachment version but the page will show other session's modifications."

Where in fact it is not the case. I tested with a new diagram on a new page. It has the same issue. I tried with different browser, same problem....

image.png

Chrome console:

image.png

6 answers

1 accepted

1 vote
Answer accepted

This issue should now be resolved.

It is solved! Thank you for your help!

Like # people like this

Hi @David Benson _draw_io_ , I'm facing the same issue at the moment. Do you have any hint for me, how I can solve this? I do see the new version but upon save the errors appear... Thanks, Julius

Hi, so you have a save problem in draw.io for Confluence Cloud. Since this post is opened a year ago, my initial advice would be to repeat all the steps in a different browser and Incognito mode in order to see if you still have an error reported.

Also, clear the cache and temporarily disable all browser extensions.
Incognito mode is great for testing cause it is cache and extension free (cache and extensions can cause some problems sometimes)

If this doesn't help, could you tell me the following, please:

* Browser version and operating system

* Do you have a problem with saving a newly created diagram only or with old diagram also when you try to save edits?

* Are you the only one having this problem or other colleagues have it also?

* Exact steps you performed (click Save&Exit top right or File > Save&Exit)?

 

And please, send us screen shots of:

* the error

* browser console when you try to save a diagram (browser console can be opened in      Chrome via Ctrl Shift J (Windows) or Cmd Option J (Mac)

* draw.io version. Can be found in expanded draw.io in Manage apps (under Settings)

 

I know it is a lot of questions, but your answers will help us get all info needed for further investigation. Thanks.

Marija, draw.io support

Hi Marija,

thanks for coming back so quickly! The different browser approach didn't make it, so I exported and re-imported the draw on another confluence page and that did the trick. Case solved! Best regards, Julius

Hi, 

We managed to reproduce the issue so we've assigned an engineer to your issue and will report back via support@draw.io when we have more information. 

Meanwhile, could you please try to edit a diagram by clicking Edit pencil in Confluence Cloud page where a diagram is stored, (the top right side of the screen), make changes and then click "Save" or "Save and exit". You should be able to save changes that way (we tested it at our place)

Thanks!

Regards,

Marija

Interesting, I've been having this issue intermittently today

Do you have the page in edit mode in two browsers?

1 vote

I'm having this issue today too....

Hi Lisa,

could you provide me with all details here so I can be sure what problem you have, please? I understand it is a saving issue, but need more details. If you repeat all the steps in Incognito mode and another browser (but clear cache and temporarily disable all browser extensions first), is saving working well?

If this doesn't help, could you tell me the following, please:

* Browser version and operating system

* Do you have a problem with a newly created diagram only or with old diagrams also?

* Are you the only one having this problem or other colleagues have it also?

* Exact steps you performed (where you clicked e.g if you licked Save&Exit top right or File > Save&Exit)

* Under File > Revision history, do you see the latest version?

And please, send me screen shots of:

* the error when it appears

* browser console when you try to save a diagram (browser console can be opened in      Chrome via Ctrl Shift J (Windows) or Cmd Option J (Mac)

* draw.io version (can be found in expanded draw.io in Manage apps (under Settings)

Thanks,

revision history.PNG

Not Lisa, but will try to answer how it works for me:

  • The problem happens only when initiating edit of already defined diagram right from the page you are reviewing.
  • The problem is not happening when initiating diagram edit on the page being in edit mode.
  • Reproduced on Chrome Version 83.0.4103.61 (Official Build) (64-bit) and Safari Version 13.1.1 (15609.2.9.1.2) running MacOS Catalina 10.15.5
  • Draw.io version is 13.1.14
  • When getting to Revision history the version which should became 'current' after save is still available

Here is a screenshot of error:

SaveIssueScreenshot.png

FYI: I've put a description of workaround for everyone's use in separate comment. Some additional information could probably found there.

Let me know if you need some additional information about how the issue happens as I can reproduce it without much issue now. 

Hi @gcaggia and welcome to our Community!

As this issue is pretty hard to reproduce, I'd recommend writing to the draw.io technical support directly:

support@draw.io

and include the Confluence logs.

I think it'd be the shortest way.

It seems that I have found at least a workaround for this. For me the problem happens when you issue editor while page not being in edit mode. This could be done by pressing 'Edit' button when viewing page.

But if I initiate page edit first, then scroll to my chart and start editing, I can then save changes.

Also, I have noticed one another thing. If your chart is not saved, changes are not lost actually. When starting edit and looking at the chart in non-changed state, go to "Revision history" in "File" menu. There you can restore to your previous version. This could at least help you quickly getting your changes back to the editor.

One another observation which may or may not be relevant. This has started happening to me after I have converted page to a kind of new format.

Hope that could help to someone at least till the moment the issue is resolved on Draw.io plugin side.

Thanks for your valuable information.

Although another customer also reported the same issue with converted pages, we couldn't reproduce the issue on our side. We will appreciate it if you can share with us the details of the error in the console (error code and response, which can be accessed in the Network tab of the browser console).

 

Also, how did you converted the page from the old Confluence editor to the new one?

Thanks

I have shared some details in reply to comment above made by @Marija Radovic

But here comes some more information from Network tab:

SaveIssueScreenshot-Network.png

 

SaveIssueScreenshot-Request.png

The page was converted by just pressing special popup in the footer:SaveIssueScreenshot-Conversion.png

This one appears if you have some page created before Atlassian provided "new Confluence editing" feature. Then you go to edit it and it proposes you to convert. The process passes smoothly. Please note, that for this particular page I have got no Draw.io diagrams on the page before conversion.

Thanks for the details, we'll try to reproduce

I just want to confirm that editing within Confluence Page Editor works. Only direct editing from the viewer doesn't. Correct?

Editing within the Editor was a work around that worked for me.  

Like Ashraf Teleb likes this

Yes, the issue only happens if issuing edit from the page view directly. Initiating edit page first and then editing chart works as expected

Like Ashraf Teleb likes this

Can you please confirm that this Confluence bug is the cause:

https://jira.atlassian.com/browse/CONFCLOUD-69902

(Simply, does the page contains any links without ri:space-key?)

 

If that is the case, we have no control over this error. We will show a more informative error message suggesting editing within Confluence page editor.

Thanks

I am sorry, I am not so deep in understanding what is defined in ticket you refer. So it has taken some time for me to get to the point and check.

Indeed you were right. I've had one link which was formed w/o `ri:space-key`. I have managed to find out this my looking at PUT body which was sent to Confluence server. When I have removed it I was able to initiate Edit right from the page view and saved it successfully. Happily - there was only one link like that.

For those, who is looking for workaround, here is one that worked for me:

  1. Find links on the page you experience problem which point to confluence pages/JIRA tickets. These are ones which target you define by selecting from drop down.
  2. Drop them and redo as plain hyperlinks which just point to a target page URL

So, instead of link like that:
IncorrectLink.png

You should have link like that:

CorrectLink.png

Like Ashraf Teleb likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

Lessons and Learnings: Six Months of Working Remote [Discussion]

Hey there, folks! For most of us, the past six months- yes, you read that right- have been a journey. More people than ever before have pivoted to working remotely, and navigating being on-scre...

8,196 views 6 6
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you