Default theme issue in Confluence 5.10.0 from Confluence 5.4.0 on one space. Missing sidebar

This question is in reference to Atlassian Documentation: Switch to the Default Theme

After switching a space back to the default theme, the sidebar is blank.

I followed the troubleshooting guide on https://confluence.atlassian.com/doc/switch-to-the-default-theme-790795554.html however I have been unable to amerlorate the fault.

I changed back to documentation theme and I get the side bar back and confirmed no layouts had been changed from the defaults. Upon reverting to the default theme the sidebar once again is blank.

Are there any additional troubleshooting steps I can look into?

Cheers 

6 answers

1 accepted

Managed to fix this in test with some rather naughty poking about in the back in SQL.

I came across this: https://jira.atlassian.com/browse/CONF-41425

Which made me suspect this was the issue I had. There was enough detail to directly poke about in my test environment, so I just checked the AO_187CCC_SIDEBAR_LINK table for something that looked wrong and spotted duplicates. 

I had no idea what I was doing, entirely on hunches I just deleted the newer keys which looked like duplicates for the space (Its what test is for right?)  and deleted the rows directly from the SQL table.

While it worked, I have no idea if this will cause further issues later on, so the plan is to wait for the bug to be fixed and implement the official fix on the live environment. (As it would appear a fix is currently under review)

Only mentioning if any of you are unable to wait.

 

Cheers,

Jon

1 vote
Davin Studer Community Champion Jun 20, 2016

How do you have your sidebar configured?

image2016-6-20 9:16:1.png

As you can see, nothing in the sidebar:

image2016-6-20 19:1:15.png

 

Only on this space however, its fine on all other spaces:

image2016-6-20 19:1:57.png

Cheers

1 vote
Davin Studer Community Champion Jun 20, 2016

Do you have any stylesheet rules setup for this space that could be affecting the sidebar? You could get to it by the following URL. Also, is it every page of that space or just the home page of that space?

http://{yourserver}/spaces/viewstylesheet.action?key={spacekey}

Hi Davin


It only affects this one space, the sidebar is missing only on this space and any child pages of this space. As far as I could tell, there are no custom fields on any aspect of the space either:

image2016-6-21 10:1:26.png

 

Prior to jumping on the forums, I set a working space to the Documentation theme, and the space with the broken sidebar and methodically clicked through every option for custom settings and ensured they were the same. All settings are on default.

I then changed both spaces back to the default theme and checked every option there also.
 

image2016-6-21 10:7:33.png

image2016-6-21 10:8:41.png

 

As far as I can tell, every option on both documentation theme and default theme are defaults for the space with the missing sidebar, compared against the other spaces they are also identical on the options. 

The issue will no doubt be a layer 8 fault on my side on some trivial option I have overlooked, but if you can point me in that direction I would be grateful.

Cheers.

Jon

I'm running into exactly the same situation as Jon experienced.

As of today i noticed one of my spaces did not display the pagetree.
I started looking into this issue and reading up on solutions - nothing seemed to work and then i ran into this thread..

All spaces are using the same 'Global Look and Feel' template ( no code attached to it, just some simple color branding )

If I change to the documentation theme, the tree view works but there are also no buttons at the bottom.
Exactly the same situation as described previously.

I went into the AO_187CCC_sidebar_link table in the Postgre database but there are no duplicates here.

So i'm at a complete loss as to what might be causing this, anyone have any other bright idea's?

Regards,
David 

 

Hi David,

I am using a SQL back end for the database, and I ended up applying this 'fix' on our live environment in the end as it was becoming quite irksome.

I take it you followed the link to here: https://jira.atlassian.com/browse/CONF-41425

Confluence --> Tables -->

image2016-11-8 12:2:47.png

 

Could you post a screen shot of the content:

image2016-11-8 12:5:10.png

Hi Jon,

Yes, i ran into that article after i ran into this thread.

As for the screenshot :
sidebar_link.png
LSFS is the space where i'm having the issue. 

Do you have a test system running?
If so can you do a live to test copy and then remove line 57 from the table?

image2016-11-8 13:10:24.png 

Under the advice of 'I have no idea what I am doing' if you don't have a test system, please do not perform this action as I genuinely don't know what will happen in this case. I have not seen the space-calendar-sidebar-link in my system. Do you have Team calendars for confluence? (I don't)

Cheers,
Jon 

Hi Jon,

Sadly enough no test environment here :/ 
As for the Team Calendar - Its something my boss recently installed and I overlooked.
It works fine on the other spaces, the only thing it does is add a link in the navigation pane.

Funny thing however > when i turn the add-in off.. the sidebar seems to work again in the LSFS space!

I might have hit something however going through more articles >  https://jira.atlassian.com/browse/CONF-41449

We started our JIRA experience with Confluence in the cloud, after a month or 2 we migrated towards our own hosted install.. Guess what  space got exported from cloud and imported into the serverversion? smile 
Possibly there is some old cloud setting causing some issues in combination now with the team calendar. The article mentions deprecated theme settings..

I'm looking at options to copy my content into a newly created space - i'm curious as to what effect that will have. However since I have to change the space key to do this, it will probably cause all my links to break.. :/  
If no luck, i'll dig deeper in the calendar thing.

Thanks for the time and effort!
David 

Hi Jeffry,

I am assuming you are on the same system as David, otherwise I am getting my wires crossed with this next answer:

If you have Team Calendars installed I am willing to bet its that duplicate key then. When you turn the add-on off they keys will not be called.
Could you remove access to confluence to all users, back up the database and try removing that duplicate key (line 57 as 56 is the same):
image2016-11-8 13-10-24.png 
It would appear to me that there are two copies of the Team-Calendars for the LSFS space attempting to launch in the sidebar, which my guess is causing it to fail to appear at all.

If it works, revert the database back anyway and log a ticket with Atlassian support to look into it. I really don't know enough to recommend doing it and support should be able to steer you in the right direction. https://support.atlassian.com/servicedesk/customer/portal/14

Cheers and Good luck!,
Jon

Hi Jon,

My browser decided to use a different userid when posting my previous post apparently ( Jeffry is the JIRA license holder for our company - so I have to use his account once in a while .. )

Interesting find there on line #56 and #57 - i'm going to see if I can make some progress via this.

Thanks a ton!

Regards,
David 

Hi!

I'm having the same problems, after upgrading to confluence 5.10 my home dashboard sidebar doesn't show, neither the buttons.

Hi Samanta,

Did you do this live directly or is this just your upgrade test prior to putting it live?
If it is your test environment, just open the back end SQL and delete the duplicate keys out and the sidebars will come back:

image2016-7-14 9:8:51.png


The sidebar was only missing on one of my spaces, not all, so it was a case of locating the newer duplicate keys and deleting them directly from the table.
AO_187CCC_SIDEBAR_LINK table screenshot.png 

Note: This was only for one of my spaces, initially this was caused by the Documentation theme, which after switching to the default theme the side bars came back correctly.
https://confluence.atlassian.com/doc/switch-to-the-default-theme-790795554.html

If this is your live system I would advise against making changes directly to the SQL back end unless instructed by Atlassian support.

Hope this helps.

Cheers,
Jon 

Hi,

i've resolved the problem, here's what i've done: 

  1. Acess General Configuration > Layouts.
  2. Restore the Global Layout to the Default.
  3. Acess de home dashboard.
  4. In the end of the side bar, there's a option "Give me back my old sidebar" or something like. I clicked in this option, and my old sidebar appeared again: dashboard.png

 

Glad you got it all sorted.
I made the error of thinking you were after the new side bar menu:

image2016-7-15 15:33:28.png

 

Cheers,

Jon

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jul 10, 2018 in Confluence

We want to see the templates you've created in Confluence!

Hi Community, Jessica here from the Confluence Product Marketing team!  July’s community challenge is all about sharing pictures  — and as an extension of our first post on what ...

621 views 21 11
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you