Confluence won't open

I'm trying to open http://localhost:8090/confluence and http://localhost:8090 and I get this:

This site can’t be reached

localhost refused to connect.


ERR_CONNECTION_REFUSED. I'm going through the Dragon Slayer challenge, Stage 3. 



2 answers

1 accepted

0 votes
Answer accepted

Permissions! Though I'm a local administrator, I went all out and set all users to full control (not just modify, though I'm sure modify would have done the trick). I'm in!

0 votes

Hi, Gabriel!

Nice that you're using the Atlassian Dragon Quest! Let me help you out here. Now, the Dragon Quest is only meant to be used with the versions listed, so they're going to be quite out of date. It's meant to challenge you so there may be some missing pieces that you will need to discover. It's also not meant to be used when setting up a production Confluence instance, so if this is your purpose then you will want to make sure to follow the current documentation on installing Confluence.

Now, I'm not sure which version of Confluence you are installing, but have a look here at my conf/server.xml file from my 6.4.1 installation:

Screen Shot 2017-09-29 at 1.49.06 PM.png

You can see I changed the port 8090 to 8641, so make sure that you still have 8090 next to that connector port if that is the port you want to use. You also want to make sure nothing else is running on that port, or that you don't have another Confluence instance running on the 8000 port, if you had multiple set up.

Additionally, that context path will be blank by default, and just show "" meaning you can only load at localhost from that port. so localhost:8090, for example. If you have Jira *and* Confluence running then you will want to set a Context path there. This would then be "confluence" since that's where you were trying to open Confluence. So please compare what you're using with this file.

One more thing, you want to make sure that port 8090 is open on your firewall.

Let me know if this helps or if you have any questions.

Kind Regards,

THANKS for your response, Shannon. I've turned my firewall completely off. My computer is not even listening on port 8090. It's listening on 8080 and 8005. I already have JIRA installed. It works fine. Any other ideas? I'd really like to get over this hurdle.


Can you show me those lines in your server.xml file? 

Can you confirm you fully stopped and started Confluence again from inside the /bin folder? You can show me the lines that it tells you after you run and

One more thing you can do is look at the Confluence log itself and see what errors occur after the Starting Confluence... message.

Kind Regards,

I looked in services (since it's supposedly running as a service) and there isn't a service named Confluence. There's only one Atlassian service, and that's JIRA.

Hi Gabriel,

Perhaps Confluence didn't start properly? Are you on Windows or Linux?

Have a look at Start and Stop Confluence to make sure you are starting it properly. 

You can still look at the atlassian-confluence.log file for any startup errors: Confluence Startup Problems. If you need help, just let me know what errors you see under Starting Confluence... in the log file.

Kind Regards,

Now I get:

HTTP Status 500 - java.lang.IllegalStateException: Spring Application context has not been set


And there were errors when I ran start-confluence



I'm in Windows.

"Failed to create work directory" doesn't sound good.

Any chance you could remote into my machine for a minute?

It could be a permissions problem.

Hi Gabriel,

At least we are getting closer! Can you try having a look at this:

The scratchDir specified is unusable

It seems the home directory you specified is having issues being created, most likely due to permissions. That article will help you to correct them.

Otherwise, I'm not able to remote into your machine, but I could give you a call on Monday. Let me know if you're still having issues after this evening and I'll be creating a ticket for you in our support system where you can provide your contact information.

Kind Regards,

That was it. Though I'm a local administrator, I went all out and set all users to full control (not just modify, though I'm sure modify would have done the trick). I'm in!

Thanks so much for you help. If you hadn't told me about the BIN folder, I never would have found that error message to google, which led me to permissions.

Great news!


Thank you for confirming that :) Glad you're up and running.

If you have any other troubles feel free to ask a new question and you can even tag me on it.

Kind Regards,

The problem came back! Just randomly. 

Now it's working so long as I leave the command line open after running the batch script.

Hi Gabriel,

This is a side-effect of running Confluence on Windows when it's not set up as a service.

You can set up Confluence as a service by following this article:  Start Confluence Automatically on Windows as a Service

One thing to keep in mind when running Confluence as a service on Windows is that it uses the Java installed on the computer rather than the settings built into Confluence. Therefore, you'll want to make sure to have the latest supported Java installed on your Windows machine and properly set the Java home. Have a look at Installing Java for Confluence. You'll want to set up that first and then any system variables for Java and then you can set up Confluence as a service.

Have a look at that and let me know if you have trouble :) 

Kind Regards,

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Tuesday in Confluence

Confluence Admin Certification now $150 for Community Members

More and more people are building their careers with Atlassian, and we want you to be at the front of this wave! Important Dates Start the Certification Prep Course by 2 April 2019 Take your e...

204 views 2 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you