Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence server not listening on 8443 after https configuration Edited

My server is not listening on port 8443. 
I followed this walkthrough:
https://confluence.atlassian.com/doc/running-confluence-over-ssl-or-https-161203.html

sudo netstat -taplnu | grep 8443
-- nothing

The firewall is off

I've tried restarting the device several times and confluence. The normal port 8090 works fine.

server.xml:

<Server port="8000" shutdown="SHUTDOWN" debug="0">
<Service name="Tomcat-Standalone">

<Connector port="8090" connectionTimeout="20000" redirectPort="8443"
maxThreads="48" minSpareThreads="10"
enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
protocol="org.apache.coyote.http11.Http11NioProtocol"/>

<Connector port="*8443" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25"
protocol="org.apache.coyote.http11.Http11Nio2Protocol"
enableLookups="false" disableUploadTimeout="true"
acceptCount="100" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLSv1.2" sslEnabledProtocols="TLSv1.2" SSLEnabled="true"
URIEncoding="UTF-8" keystorePass="pyramids-undone-excellence"/>
keystoreFile="/home/user/.keystore"/>

<Engine name="Standalone" defaultHost="localhost" debug="0">
<Host name="localhost" debug="0" appBase="webapps" unpackWARs="true" autoDeploy="false" startStopThreads="4">
<Context path="" docBase="../confluence" debug="0" reloadable="false" useHttpOnly="true">
<!-- Logging configuration for Confluence is specified in confluence/WEB-INF/classes/log4j.properties -->
<Manager pathname=""/>
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60"/>
</Context>

<Context path="${confluence.context.path}/synchrony-proxy" docBase="../synchrony-proxy" debug="0"
reloadable="false" useHttpOnly="true">
<Valve className="org.apache.catalina.valves.StuckThreadDetectionValve" threshold="60"/>
</Context>
</Host>
</Engine>
</Service>
</Server>



The service is running:

● confluence.service - Confluence
Loaded: loaded (/lib/systemd/system/confluence.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2020-10-14 18:53:28 EDT; 6min ago
Process: 3508 ExecStart=/opt/atlassian/confluence/bin/start-confluence.sh (code=exited, status=0/SUCCESS)
Main PID: 3562 (java)
Tasks: 231 (limit: 4915)
Memory: 2.4G
CGroup: /system.slice/confluence.service
├─3562 /opt/atlassian/confluence/jre//bin/java -Djava.util.logging.config.file=/opt/atlassian/confluence/conf/logging.properties -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djdk.tls.ephemeralDHKeySize=2048 -Djava.protocol.handler.pkgs=org.apache.catalina.webresources -Dorg.apache.ca
└─3840 /opt/atlassian/confluence/jre/bin/java -classpath /opt/atlassian/confluence/temp/3.1.0-master-022ca438.jar:/opt/atlassian/confluence/confluence/WEB-INF/lib/h2-1.4.196.jar -Xss2048k -Xmx1g synchrony.core sql

1 answer

*8443 isn't a valid port, try it with 8443 instead.

I'm sorry, that seems terse, I was too quick with the <enter> key.   I wanted to say that the chunk of config file that you've given us seems broadly correct, but the port setting is invalid, so Tomcat is ignoring it - port="x" needs to have a plain number, but I think you've miskeyed a * into it.

<Connector port="8443" maxHttpHeaderSize="8192"
maxThreads="150" minSpareThreads="25"
protocol="org.apache.coyote.http11.Http11Nio2Protocol"
enableLookups="false" disableUploadTimeout="true"
acceptCount="100" scheme="https" secure="true"
clientAuth="false" sslProtocol="TLSv1.2" sslEnabledProtocols="TLSv1.2" SSLEnabled="true"
URIEncoding="UTF-8" keystorePass="pyramids-undone-excellence"/>
keystoreFile="/home/user/.keystore"/>

After restarting the device and the confluence service,
sudo netstat -taplnu | grep 8443
-- still nothing

I found the exact cause:

15-Oct-2020 18:52:29.749 SEVERE [main] org.apache.catalina.util.LifecycleBase.handleSubClassException Failed to initialize component [Connector[org.apache.coyote.http11.Http11Nio2Protocol-8443]]

I have no clue how to fix this.
The keystore file is in the correct place:
-rw-r--r-- 1 user user 2639 Oct 15 18:50 /home/user/.keystore

That is not the "exact cause", there's a whole load of related error messages around that which might tell you a lot more.

Could you look at the application log instead?  I'd like to see what Confluence is trying to do as it starts up, so look to <confluence home>/log/atlassian-confluence.log (ideally, stop all confluence processes, clean out the log directory by moving the current files out, and try restarting it.  This will give you a single set of logs that you know is all about the current start up)

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS
Community showcase
Published in Confluence

Announcing Team Calendars in Confluence Data Center

Hi Community! We're thrilled to share that Team Calendars for Confluence is now a built-in feature for Confluence Data Center releases 7.11 and beyond.  A long time favorite,  Team Cale...

75 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you