Confluence:Inserting existing variable in template gives double-dollar and doesn't pick up value

Running Confluence 5.2.3 downloaded.

When I create a new template and create a variable (called firstVariable) it appears as "$firstVariable". When I try to insert that variable elsewhere in the document to pick up the original value it creates and inserts a new variable called "$$firstVarable" which is unconnected to the data in "$firstVariable". Effectively I have to double-up all my variables and use the double-dollar version everywhere.

Surely this cannot be the designed behaviour! I've tried it in different browsers, and in different Spaces but it does the same thing every time. Is this a known issue? Is there some configuration setting I am missing?

Please help!

1 answer

1 accepted

0 votes
Accepted answer

It looks like this is a bug in the "insert template items" button. If I just use the keyboard, type a dollar and select from the pop-up list then the variable is inserted just fine without the double-dollar.

I'll raise an issue with support and see what they say. At least there is a workaround so I don't have to duplicate all my variables!

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 24, 2018 in Confluence

Atlassian Research opportunity with Confluence templates

Do you use templates with Confluence? Take part in a remote 1-hr workshop. You'll receive USD $100 for your time!   We're looking for people to participate in a   remote 1-hr workshop...

1,526 views 25 14
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you