Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Code Block Macro - kr & bg

When using the code block macro and just typing the commands like bg or kr (both used for linux), the block clears itself and goes blank. Anyone else having this issue/ has a work around. 

 

Running Confluence 7.4.4 (Issue also present in Safe Mode)

1 answer

0 votes
Diego Atlassian Team Apr 01, 2021

Hello there @Staphon Arnold!

This is an odd behavior. I tried to replicate it but had no luck. Or maybe I am lucky and this did not affect my instance!

Anyway, I would like to ask you a few questions. Here we go: 

  1. Would it be possible for you to give us an example of code where this was triggered?
  2. What is the syntax highlighting that you use when this happens?
  3. Is there a set of steps that you need to follow for this to happen?

 

Let us hear from you!

Storage Format:

<ac:structured-macro ac:macro-id="11255452-9d96-4eed-8658-29849af1131d" ac:name="code" ac:schema-version="1">
<ac:plain-text-body><![CDATA[kr]]></ac:plain-text-body>
</ac:structured-macro>
<p class="auto-cursor-target">

Screen Shot of settings (Just using the defaults, but changing any of the parameters yields the same results.)

Screen Shot 2021-04-01 at 8.12.38 AM.png

Not sure what other information to provide. LMK if you think of anything. Again, issues is still happening in Safe Mode. 

Diego Atlassian Team Apr 09, 2021

Hey, thanks for providing this information!

I am not able to replicate the behavior, @Staphon Arnold.

I started a fresh installation of Confluence 7.4.4 and the behavior is as expected:

In view Mode

Screen Shot 2021-04-09 at 11.23.18.png

 

In Edit Mode

Screen Shot 2021-04-09 at 11.23.50.png

 

Macro settings dialog

Screen Shot 2021-04-09 at 11.24.06.png

 

I wonder if there is a specific set of steps that you need to take for this to happen. Would it be possible for you to describe, step by step, the workflow that leads to this result?

Also, could you please check the following:

  1. What happens if you create a new page and try to replicate the behavior?
  2. Is the behavior present in already existing macros?

 

You can also try to clear the plugin cache to rule out problems with the data stored by the macro:

Let us hear from you.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS
Community showcase
Published in Confluence

Confluence Mythbusters: Does Atlassian even use Confluence?

Hi, Confluence collaborators! As part of #Confluence-Collaboratory month, we’ve created a very special Mythsbusters segment, where we're dive into an interesting myth and uncover the truth behind i...

1,529 views 7 29
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you