Cannot log in as admin after installing Confluence evaluation

I just installed the evaluation version of Confluence but am not able to log into the dashboard with the "admin" account that was created. Has anyone encountered this issue?

5 answers

0 vote
Penny Wyatt Atlassian Team Aug 04, 2011

Hi Dan, I've just updated the question title to be a bit more specific.

0 vote
Penny Wyatt Atlassian Team Aug 04, 2011

So you created an admin user and set the password during the Confluence Setup Wizard, and immediately afterwards, weren't able to succesfully log in with the same username/password? I hate to say it, but the most likely cause - assuming you haven't done any imports or tried anything fancy with external user management - is just a simple typo when creating the user (or a caps lock issue).

There are instructions on recovering the admin account here - http://confluence.atlassian.com/display/DOC/Restoring+Passwords+To+Recover+Admin+User+Rights - but to be honest, since it's an eval and you haven't even got in yet, the quickest solution is just to wipe the database and start again:

1) Stop Confluence

2) Wipe the database - if you're using an external database system such as Postgres, drop and recreate the database. If you're using HSQL, just delete the "database" directory in the Confluence installation directory.

3) Start Confluence again and go through the wizard.

Let us know how you go, please!

Thank you for the quick reply but this is the second time I have gone through all the installation steps and both times I get stuck when trying to login. I left the default "Admin" username with a very simple password but neither time was I able to log into the dashboard. I am using SQL server 2008 for the database, not sure if that has anything to do with it.

Thanks

Penny Wyatt Atlassian Team Aug 04, 2011

Hrm, interesting. I've just downloaded a clean version of Confluence 3.5.9 and run through the evaluation setup wizard, and after the admin account creation step, it didn't even ask me to log in, but logged me in automatically.

Obviously you're not getting this same experience - could you please clarify what happens for you? You start the setup wizard, create the admin account, complete the wizard, and then it's dumping you at a login prompt instead of the Confluence dashboard?

Sorry you're encountering such issues with what is normally a quick and easy process!

I was able to reinstall Confluence and finally got it to work. I had it working for a couple of days but now I am having a new issue. When I launch the startup.bat the command prompt opens up but shortly after it crashes. I wont stay open longer than a minute or two. Any suggestions?

is you bring up a cmd window and run startup.bat (cd to the directory, the ,\startup.bat) directly in the window, it will allow you to see what the problem is. My guess is that its trying trouble connecting to a database, or you are out of memory.

I have already tried that. When i launch startup.bat from cmd window it launches the application and it seems like it is working but only stays open for a couple of minutes.

Good morning

Any more suggestions regarding the issue I am having? The application crashes within minutes of either running startup.bat through command line or when I double click on startup.bat.

What "only stays open for a few minutes"? The cmd window or confluence in your browser? That we need to figure out first.

Secondly, I would suggest installing Confluence as a service and not having it run the startup.bat because that is a domain account and not system account process.

Third, it would help if you attached a zip of all log files from <confluence-install>\app\logs and <confluence-install>\data\logs.

Thanks,

Good afternoon

The command window for Confluence only stays open for a short time before crashing. I tried to install confluence as a service but after setting it up I realized that you cannot set up confluence as a service on a 64 bit server, is this true?

Ok. I was able to install confluence as a service. I was able to start the service but after a short amount of time the service crashes thus causing the browser to crash. The JDK version I am using is 64 bit, could that be an issue?

It would be best at this point if you attached the logs from the two locations I provided.

Good morning

I was able to reinstall Confluence and finally got it to work. I had it working for a couple of days but now I am having a new issue. When I launch the startup.bat the command prompt opens up but shortly after it crashes. I wont stay open longer than a minute or two. Any suggestions?

for me it didnt work. Installed confluence, copyed password out of txt file -> wrong password. Reinstalled 3 times. No success. Wrong password. Deleted confluence. Is there any program simmaler to confluence I can try? Confluence seems not to be a good programm if standard installation does not work.

There is no password to copy out of a text file.

When you install Confluence, it asks you to create an initial admin user, and you give it a password.  You need to remember that password to log in after completion.

Yes. Lets say you choose "password" and save it in a textfile to be shure that you do type it correctly. Then you log in with the password you copied out of textfile. Login sucessfull. Then you click on administration, enter the same password what was sucessfull before and voila: "wrong password". Tryed it with 3 new installations. Found out later, that in EDGE it was working to login. Exacly same password. Firefox: "wrong password".

Sounds like you've set something wrong then.  Are you using odd characters in the username or password (anything not a-z or printed on a number key on your keyboard?).  Check the log file to see what the error is.

Is this still an open item. Im having this exact issue. I've installed Confluence 6 times (literally) tonight. Every single time I've taken care to ensure that I'm getting the password correct. The last time I reduced the password down to 8 characters using only letters and numbers. 

I tried setting the password using the recovery env variable, that didn't work either. 

This is seriously crazy...

 

Edit: this is NOT a trial license, it's one I bought - just in case someone things that may matter. 

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Apr 13, 2018 in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

2,691 views 25 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you