Cannot add Balsamiq Mockups to the page

Error message:

Balsamiq Mockups for Confluence Error

You do not have permission to add or edit UI mockups.

If you think this message shouldn't apply to you, please consult your administrators about getting the necessary permissions.

What permissions do I need?

5 answers

As far as I know you need to be a member of the "Balsamiq" group, where the licensees are defined. But we use it in Jira.

Hi, thanks for the answer. I have only one permission related to "Balsamiq": balsamiq-mockups-editors. I add myself to this group but still cannot add or edit mock-ups.

we have the same issue..any solution to this?

Same problem here. I've myself in the balsamiq-mockups-editors group but I still can't insert the macro.

It's not free tool. You need to go to Gear icon > Add-ons in the Confluence header. and purchase it (They have Free Trial period).

https://marketplace.atlassian.com/plugins/com.balsamiq.confluence.plugins.mockups

This thread has just come to our attention as unanswered. sad  I know it is probably far too late to assist the people who commented in 2015 and 2014, however we wanted to at least provide some guidance for any other users who encounter this issue.

We don't know the specific issues users were encountering, however it could be due to one of the following things depending on where you purchased your license from.

IF you purchased directly from Balsamiq:

Currently plugin licenses purchased directly from Balsamiq do not have to match. You can register a Balsamiq-issued 10-editor Mockups for Confluence license on a 100-user Confluence installation.  So it could be that specific users are not set up as named editors in your instances.

Here's a FAQ on how to create named editors in Mockups for Confluence: https://docs.balsamiq.com/confluence/admin-guide/#selecting-mockup-editors


Here's a FAQ on how to create named editors in Mockups for JIRA: https://docs.balsamiq.com/jira/admin-guide/#selecting-mockup-editors

IF you instead purchased directly from Atlassian:


Matching is required for purchases made via Atlassian Marketplace.  So if you purchased via marketplace: https://support.balsamiq.com/sales/marketplace/ but do not have a Balsamiq license that matches your Server levels, your users may get an error.  Your Confluence or JIRA administrator can check the licensing in the UPM.  If it says "incompatible with product license (different number of users)" you'll need to upgrade the license in order to continue using it.

 

If neither of these seem to fix your issue using the plugin, please reach out to us.  We're here to help!  support@balsamiq.com

 

And our deepest apologies that we missed this question in Atlassian Answers in 2014.

Natalie for the Balsamiq Team

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Kesha Thillainayagam
Posted Friday in Confluence

We want to hear how your non-technical teams are using Confluence!

Hi Community! Kesha (kay-sha) from the Confluence marketing team here! Can you share stories with us on how your non-technical (think Marketing, Sales, HR, legal, etc.) teams are using Confluen...

301 views 11 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you