It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Can't install Gliffy

I recently bought a 10 User Licence and tried to install gliffy via 

https://confluence.bamberg.wienet.ads/plugins/servlet/upm

and upload the obr File (gliffy-confluence-plugin-8.4.3.opr)

Shortly after submitting and still showing a dialog "Installing gliffy..." in the background an error is show`n and "An unexpected error occured". The spinner is still active and won't finish.

Since our server is not able to access external internet ressources,
we started confluence with the following Java Startup Parameter: -Dupm.pac.disable=true.

Can this be the cause or how can i find out what the problem is?

 

1 answer

1 accepted

0 votes
Answer accepted

Hello,

You might be able to find the the error in the Confluence logs if you can access them. 

A common issue is the plugin size (limited to 32 MB), which can be resolved by increasing the packet size to a higher number (gliffy is around 76 MB)

Hope it helps

this could indeed be the problem. I changed therefore maxAllowedContentLength in web.config (IIS) 


<system.webServer>
<security>
<requestFiltering>
<requestLimits maxAllowedContentLength="2147483648" />
</requestFiltering>
</security>
</system.webServer>

 

After i restarted IIS, any requests produced a "500 - internal server error". Then i removed the new config parameter and tried again. Still a 500 internal error.

This are the errors a see in the logfiles:

... 25 more
Caused by: java.net.SocketTimeoutException: connect timed out
at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketImpl.java:85)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at org.apache.http.conn.ssl.SSLConnectionSocketFactory.connectSocket(SSLConnectionSocketFactory.java:339)
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:142)
... 39 more
2019-09-02 18:37:04,460 WARN [Caesium-1-1] [impl.schedule.caesium.JobRunnerWrapper] runJob Scheduled job migration-plugin:plugin-version-checker#c4659139-ad37-4a4f-8248-4d4cb0d4656e completed unsuccessfully with response JobRunnerResponse[runOutcome=FAILED,message='Failed to check plugin version']
2019-09-02 18:41:19,787 WARN [Caesium-1-3] [impl.schedule.caesium.JobRunnerWrapper] runJob Scheduled job LaasPerformanceLoggingJob#LaasPerformanceLoggingJob completed unsuccessfully with response JobRunnerResponse[runOutcome=ABORTED,message='LaaS performance logging is turned off']

 

Do you have any ideas what the problem could be?

Hello, I imagine you are affected by this known issue: https://jira.atlassian.com/browse/CONFSERVER-55875 according to the logs.

You can use the workaround to disable it: 

Disable the "scheduledjob.desc.LaasPerformanceLoggingJob" from Settings/Cog > General Configuration > Scheduled jobs

Hello, 

 

i just realized that the root cause of my problem was i wrong syntax in web.config. 

Now, with the increased UploadLimit everything works.

Thanks for your help!

Like John Almeida likes this

That's great, glad you solved it!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Confluence

What project did you transition or start on Confluence with the shift to remote work?

It’s been great to hear from fellow users over the last few weeks about the best tips and fun moments you’ve had working on Confluence since the transition to working remote. I’d love to keep the c...

227 views 3 8
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you