Can not add JIRA users in Confluence

Hi, when i tried to add JIRA Users in Confluence i got this error:Capture 2017-12-04 at 17.07.45.png

I am using JIRA 6.3.10 and Confluence 6.5.0.

What it can be? Thanks!

1 answer

0 votes
Ann Worley Atlassian Team Dec 21, 2017

Hi Stanislav,

The ApplicationPermissionException is probably a whitelist issue in the Jira setup. Please see the resolution on: Exception when delegating user management to JIRA

I am concerned that the response from Jira has those garbled characters. If you still have trouble connecting Confluence to Jira for user management after configuring the whitelist, please make sure compression is disabled in both applications. For JIra: Gzip compression as in Configuring JIRA application options and for Confluence, http compression: Compressing an HTTP Response within Confluence.

I look forward to hearing whether you can connect to Jira as expected after configuring the whitelist and compression options.

Thanks,

Ann

 

Hi, thanks you.

But i turned off compressions in all applications and checked my whitelist and all connections is good, i mean  incoming and outgoing. And it didn't help me. 

Ann Worley Atlassian Team Dec 26, 2017

Hi Stanislav,

I understand you went into Jira User Server in Jira and verified that the whitelist contained the IP address of the Confluence server. You also turned off compression for both Confluence and Jira, but you still see the same error message when you are creating the User Directory for JIra in Confluence.

Please check the application logs for each application for related errors. The Jira log is: 
<Jira_home>/log/atlassian-jira.log

  • The Jira Home Directory is defined in <Jira_Install_Directory>/atlassian-jira/WEB-INF/classes/jira-application.properties

The Confluence log to check is:
<confluence_home>/logs/atlassian-confluence.log

  • The Confluence Home directory is the path defined in the following file: <confluence_install>/confluence/WEB-INF/classes/confluence-init.properties

Please post any error messages you find to this thread so I can help investigate. Especially any entries that include:

Connection test failed. Response from the server:

Please check any stack traces you find for a "caused by" line so we can hopefully get a more detailed understanding of why the ApplicationPermissionException error is being returned by Jira.

Thanks,

Ann

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 11, 2018 in Confluence

What are your project planning tips?

Hello Community,  Jessica here from the Confluence product marketing team! Today I wanted to get your takes on project planning –– what works, what doesn’t, how do you know if you’re doing it r...

248 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you