Bugged text on macro buttons in editor

Wrong codepage? i tried en_US and ru_RU locale - no luck

Confluence 6.4.3


1 answer

1 accepted

0 votes
Accepted answer

Hi Nikolay,

We recommend UTF-8 for Confluence. 
Have a look at Configuring Character Encoding for more details.

Kind Regards,


Thanks for reply!
But no luck - encoding already set to UTF-8. I tried to set it to Windows-1251, but macro definitions still same.


it's a fresh install.

Also, it seems like that this error appearing only on macro in editor mode. Everything else is ok


Thank you. Can you help us to understand where exactly you're seeing this, and what are the circumstances? Since at this time we are only seeing a very tiny screenshot from your instance it's hard to tell what is being encoded improperly.

Kind Regards,


i'm running on Centos 7.4, fresh install

And this bug caused by missing packages with Dejavu fonts.

So after installing it:

yum install dejavu-fonts-common dejavu-sans-fonts dejavu-sans-mono-fonts

 my problem was solved

Glad to hear, Nikolay! If I see this issue again I will suggest the same.

Take care and have a pleasant week.

Kind Regards,

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in New to Confluence

How to use Confluence Cloud for stakeholder management

Most of us don’t need much convincing that stakeholder management is important. It just makes sense that keeping everyone in-the-know on projects and assigning clearly defined roles is key to having ...

1,182 views 4 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you