Atlassian Confluence: Creating pages hangs forever behind apache proxy.

Hi everyone.

I followed the install guide for confluence successfully.

It fully works when accessing through IP:8090, creating page pop ups works instantly.

I am trying to put it behind a proxy to serve it's own domain name. Here the problem comes: the creating pages popup doesn't load anymore.

Here is the apache config (same as https://confluence.atlassian.com/doc/using-apache-with-virtual-hosts-and-mod_proxy-173685.html) : http://termbin.com/rg8u

Does anyone have the same problem ?

Regards,

Note that I had this issue using Debian 8 (current setup) but also with Ubuntu 14.04.
I also tried different versions of Confluence (.13 and .14), I currently run .13 on Debian 8 64 bits.

 

-- EDIT --

I have an insight about the issue, from apache logs:

ip - - [19/Oct/2015:15:07:12 +0200] "POST /rest/analytics/1.0/publish/bulk HTTP/1.1" 404 370 "http://confluence.fomosapiens.de/dashboard.action" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0"

See that 404 ? All others are returning 200 OK.

3 answers

1 accepted

This widget could not be displayed.
Daniel Eads Community Champion Oct 20, 2015

Hi Thomas, I have a couple ideas:

  1. Is your base URL reconfigured now for the domain name you are using? https://confluence.atlassian.com/doc/configuring-the-server-base-url-148592.html
  2. Can you check your server.xml file to see what connector ports Tomcat is expecting to use? This file is located in <your confluence install directory>/conf/server.xml. From the sounds of it, you should have this configuration (add any options that might be missing like proxyName or proxyPort). If you change this file, stop Confluence first so that when you start it back up, the changes take effect.

    &lt;Connector port="8090" connectionTimeout="20000" redirectPort="8443"
                    maxThreads="200" minSpareThreads="10"
                    enableLookups="false" acceptCount="10" debug="0" URIEncoding="UTF-8"
                    protocol="HTTP/1.1"
                    scheme="http"
                    proxyName="confluence.fomosapiens.de"
                    proxyPort="80"/&gt;
This widget could not be displayed.

Hi Thomas,

I am experiencing the same issue. What did you change in the vhost?

Best.

This widget could not be displayed.

Hi,

BaseURL always was right.

I solved my problems with changing some things in the vhost, and adding this to the connector as you said.

Thanks for your help.

Regards,

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Monday in Confluence

Why start from scratch? Introducing four new templates for Confluence Cloud

Hi my Community friends!  For those who don't know me, I'm a product marketer on the Confluence Cloud team - nice to meet you! For those of you who do, you know that I've been all up in your Co...

399 views 4 6
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you