Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Code not getting instrumented

I could get my WebAppplication (with JBoss on Eclipse) running using Run As and Run With Clover As but the code is not getting instrumented. I see no errors while jboss is coming up. So what configuration should i use. I successfully integrated Clover, i enabled clover for my project, my code is colored in pink, my classes have been rebuilt, i can see all the 4 clover stats tabs. But when i start using my web application its not hitting the code nor the stats are getting updated. Help is appreciated as im stuck here and support just taking too much time, cheers

1 answer

There are two potential problems:

1) Clover database (clover.db) is not accessible from JBoss

2) Clover runtime (clover.jar) is not present in class path

ad 1) Make sure that clover.db is available. If you deploy an application to the JBoss installed on your PC, then you can use an absolute path for initstring (Project Properties > Clover > Instrumentation > Initstring > use "custom value" and disable "relative to project dir"). Alternatively you can use relative initstring and provide -Dclover.initstring.basedir property for JBoss.

ad 2) You can copy the Clover JAR (e.g. from <eclipse_dir>\plugins\com.cenqua.clover.runtime_3.1.11.v20130325000000\clover-runtime.jar) to <jboss_dir>/lib directory.

Or you can add Clover JAR to the application's /lib directory (and package it into EAR/WAR).

Or you can add -Xbootclasspath/a:/your/path/to/clover-runtime.jar as VM argument in the Run Configuration.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Marketplace Apps & Integrations

Learn how to request and manage app requests in the Marketplace

G’day everyone! Super exciting news coming from the Marketplace. We have now fully rolled out the ability for end-users to submit app requests to admins directly from within the product! No longer ...

43 views 1 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you