Why all my settings and repositories are gone after restarting the server?

Hi all,

I've installed Bitbucket on Windows 2012 R2. After each restart everything is gone. It just takes my to the setup page when I try to browse my repositories.

Thanks

3 answers

1 accepted

1 vote
Accepted answer

Hi Fahad,

From your description I think it could be that, after a restart, the value of BITBUCKET_HOME is getting lost. BITBUCKET_HOME is your data directory, which keeps part of your instance's data. Can you please check this when a restart occurs? You may reference to the following documentation, depending on how Bitbucket was installed:

Regards,

Gustavo Refosco

Thank you Gustavo for your answer.

I've checked the BITBUCKET_HOME and found it was pointing to the correct directory. Then I've created some projects to see if the settings will get lost after I restart the machine. After restarting nothing is lost.

I searched for the other BITBUCKET_HOME which may hold my old settings. But no luck.

Anyways thank you again for your answer.

 

We have the same problem. We have installed as a windows service.

Running tomcat8w //ES//AtlassianBitbucket does nothing. No window pops up to change the home directory.

However running shutdown_bitbucket.bat lists the home directory as correct.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

447 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you